Bug 196543 - naming of perl-rrdtool and rrdtool-perl breaks yum update
naming of perl-rrdtool and rrdtool-perl breaks yum update
Status: CLOSED DUPLICATE of bug 196541
Product: Fedora
Classification: Fedora
Component: rrdtool (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 05:46 EDT by Marius Hjelle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-24 17:12:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Hjelle 2006-06-24 05:46:02 EDT
Description of problem:
Name change from perl-rrdtool to rrdtool-perl breaks yum functionallity.

Version-Release number of selected component (if applicable):
perl-rrdtool-1.2.13-2.fc5.i386.rpm
rrdtool-perl-1.2.13-3.fc5.i386.rpm

How reproducible:
Yes

Steps to Reproduce:
1. run yum update on day 1 ( and let it update and break rrdtool)
2. run yun update on day 2 (all normal)
3. run yum update on day 3 and let obsolete perl-rrdtool break yum
  
Actual results:
yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/4]
updates                                                              [2/4]
freshrpms                                                            [3/4]
extras                                                               [4/4]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package perl-rrdtool.i386 0:1.2.13-2.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: rrdtool = 1.2.13-2.fc5 for package: perl-rrdtool
--> Finished Dependency Resolution
Error: Missing Dependency: rrdtool = 1.2.13-2.fc5 is needed by package perl-rrdtool

*** from yum.log ***
Jun 09 18:16:05 Updated: rrdtool.i386 1.0.49-5.fc4
Jun 09 18:19:05 Updated: php-rrdtool.i386 1.0.49-5.fc4
Jun 09 19:30:51 Updated: rrdtool.i386 1.0.50-4.fc5
Jun 09 19:31:14 Updated: php-rrdtool.i386 1.0.50-4.fc5
Jun 19 19:12:33 Updated: rrdtool.i386 1.2.13-2.fc5
Jun 19 19:12:34 Updated: php-rrdtool.i386 1.2.13-2.fc5
Jun 19 21:36:40 Installed: rrdtool-devel.i386 1.2.13-2.fc5
Jun 19 21:38:07 Installed: perl-rrdtool.i386 1.2.13-2.fc5
Jun 24 00:21:53 Updated: rrdtool.i386 1.2.13-3.fc5
Jun 24 00:21:54 Installed: rrdtool-perl.i386 1.2.13-3.fc5
Jun 24 00:21:54 Updated: rrdtool-devel.i386 1.2.13-3.fc5
Jun 24 00:21:54 Installed: rrdtool-php.i386 1.2.13-3.fc5
Jun 24 00:21:54 Erased: perl-rrdtool
Jun 24 00:21:55 Erased: php-rrdtool
***

FYI:
rpm -qva |grep rrdtool
rrdtool-perl-1.2.13-3.fc5
rrdtool-1.2.13-3.fc5
rrdtool-php-1.2.13-3.fc5
rrdtool-devel-1.2.13-3.fc5

Expected results:
1) Non-breakage of yum.
2) package set to be obsolete after upgrade
3) ...

Additional info:
Comment 1 Jarod Wilson 2006-06-24 17:12:58 EDT
I believe if there is a bug there, the bug is with yum, not rrdtool, but
regardless, the *-rrdtool bits should be gone from the repo now.
Comment 2 Jarod Wilson 2006-06-24 17:15:56 EDT
I take it back, minor obsoletes/provides havoc w/the name change, not yum's
fault, but should be all better with the *-rrdtool bits gone.
Comment 3 Jarod Wilson 2006-06-24 17:32:18 EDT

*** This bug has been marked as a duplicate of 196541 ***

Note You need to log in before you can comment on or make changes to this bug.