Bug 196544 - Latest rrdtool stucks after some time using
Latest rrdtool stucks after some time using
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rrdtool (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 08:33 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.13-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-25 12:09:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-06-24 08:33:34 EDT
Description of problem:
Unfortunately latest rrdtool for Fedora Core 5 stucks after some time using, 
from HotSaNIC logfile:

--- snipp ---
Uncaught exception from user code:
       Can't locate RRDs.pm in @INC (@INC contains: ../../lib /usr/lib/perl5/
site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-
linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/
lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.
4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi 
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/
site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /
usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl /usr/lib/perl5/
vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-
linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /
usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/
vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-
linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/
5.8.7 /usr/lib/perl/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/
perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/
vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) 
at ../../lib/HotSaNICmod.pm line 9.
BEGIN failed--compilation aborted at ../../lib/HotSaNICmod.pm line 9.
Compilation failed in require at ./read-data.pl line 8.
BEGIN failed--compilation aborted at ./read-data.pl line 8.
at ./read-data.pl line 8
[Fri 2006-06-23 23:51:02] - rrdtimer [5842]: waiting for module's PID-file
--- snapp ---

The older rrdtool-1.0.50-4.fc5 works without any problem. Interesting is, that
I still can't reproduce the whole problem for months now when using my own RPM 
package of rrdtool for this. This results IMHO that it is a packaging problem
as my own 1.2.13 package works...

Version-Release number of selected component (if applicable):
rrdtool-1.2.13-3.fc5

How reproducible:
Very often.

Actual results:
Latest rrdtool stucks after some time using...

Expected results:
No stucks and strange error messages in logfiles like above.
Comment 1 Robert Scheck 2006-06-24 08:52:08 EDT
Ah and rrdtool-perl *is* installed...
Comment 2 Jarod Wilson 2006-06-24 20:26:00 EDT
Hrm, the error output isn't being particularly helpful, since its simply saying
it can't find RRDs.pm, which does indeed exist in @INC (specifically, in
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi, same place the 1.0.50
build put it). Any way to increase verbosity of what gets logged to maybe get
some more useful info?

I'm having a hard time thinking how this could be a build issue, since RRDs.pm
is essentially nothing more than a text file that gets copied into place
straight out of the source tarball... But the failure versus your build
certainly is interesting.

For comparison, can you attach the spec you're using for your own build?
Comment 3 Robert Scheck 2006-06-25 12:09:26 EDT
As far as I can see, the naming misery perl-rrdtool vs. rrdtool-perl caused
some strange yum confusion which was the reason this problem. Maybe other 
factors also were involved, too, because I'm not able to reproduce the same 
situation now, when upgrading from an older rrdtool to the latest one.

Note You need to log in before you can comment on or make changes to this bug.