Bug 196546 - xfce4-wavelan-plugin doesn't work on kernel 2.6.17
xfce4-wavelan-plugin doesn't work on kernel 2.6.17
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfce4-wavelan-plugin (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 10:59 EDT by Heiko Adams
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.5.3-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-20 07:11:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from cat /proc/net/wireless with the plugin working (238 bytes, text/plain)
2006-07-06 12:01 EDT, Alec Edworthy
no flags Details
Output from cat /proc/net/wireless with the plugin NOT working (238 bytes, text/plain)
2006-07-06 12:02 EDT, Alec Edworthy
no flags Details
output from iwconfig under a kernel where the plugin works (482 bytes, text/plain)
2006-07-14 04:27 EDT, Alec Edworthy
no flags Details
output from iwconfig (stdout and stderr) under a kernel where the plugin does NOT work (665 bytes, text/plain)
2006-07-14 04:28 EDT, Alec Edworthy
no flags Details
iwconfig output under 2.6.18-1.2200.fc5 where the plugin does not work (702 bytes, text/plain)
2006-10-18 03:18 EDT, Alec Edworthy
no flags Details
Contents of /proc/net/wireless under 2.6.18-1.2200.fc5 where the plugin does not work (238 bytes, text/plain)
2006-10-18 03:19 EDT, Alec Edworthy
no flags Details

  None (edit)
Description Heiko Adams 2006-06-24 10:59:06 EDT
Description of problem:
After upgrading to Kernel 2.6.17 the xfce wavelan plugin doesn't work anymore

Version-Release number of selected component (if applicable):
0.4.1-5.fc5

How reproducible:
allways

Steps to Reproduce:
1. start xfce
2. add the wavelan plugin to the xfce bar
3. take a look at the plugin
  
Actual results:
the plugin shows a red bar and reports that no wavelan device was found

Expected results:
the plugin should show how good (or bad) the current wlan connection is

Additional info:
I'm using the ralink rt2500 opensource driver 1.1 b4 from
http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page
Comment 1 Christoph Wickert 2006-06-26 08:08:05 EDT
Heiko, what does /proc/net/wireless look like with both kernels?
Comment 2 Heiko Adams 2006-06-26 14:38:42 EDT
On Kernel 2.6.16 it looks like this:
$cat /proc/net/wireless
Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
 face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 20
 wlan0: 0000   75.  177.   50        0      0      0      0      0        0
Comment 3 Heiko Adams 2006-06-26 14:39:53 EDT
(In reply to comment #2)
> On Kernel 2.6.16 it looks like this:
> $cat /proc/net/wireless
> Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
>  face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 20
>  wlan0: 0000   75.  177.   50        0      0      0      0      0        0
> 
I'm sorry. This is what /proc/net/wireless looks on Kernel 2.6.17
Comment 4 Christoph Wickert 2006-06-26 15:57:24 EDT
(In reply to comment #3)
> I'm sorry. This is what /proc/net/wireless looks on Kernel 2.6.17

Does this mean it's _excaly_ the same? If in doubt:
$ cat /proc/net/wireless > wireless.`uname -r`
$ reboot (into the other kernel)
$ cat /proc/net/wireless > wireless.`uname -r`
$ diff -u wireless.2.6.16-1.2133_FC5 wireless.2.6.17-15 139_FC5

Please post the diff it there is any.
Comment 5 Heiko Adams 2006-06-27 14:25:03 EDT
I'm sorry, but I've removed the kernel 2.6.16 before I've noticed this bug
Comment 6 Christoph Wickert 2006-06-27 17:54:45 EDT
Would you mind reinstalling it then? I can't reproduce your error here ATM
because I don't have no wlan card.

If it's a kernel thing I can't promise that upstream will provide a fix for
0.4.x, since they now focus on xfce 4.4 development and the plugin api
completely changed.
Comment 7 Heiko Adams 2006-06-28 15:14:36 EDT
How do I install the "old" kernel 2.6.16? Everytime I try rpm says that the
newer version (2.6.17) is already installed :-(
Comment 8 Christoph Wickert 2006-06-28 16:36:41 EDT
# yum install kernel-2.6.16-1.2133_FC5

I guess you also need the kernel-devel package to rebuild the kmod
Comment 9 Alec Edworthy 2006-07-06 12:01:02 EDT
Created attachment 132007 [details]
Output from cat /proc/net/wireless with the plugin working
Comment 10 Alec Edworthy 2006-07-06 12:02:32 EDT
Created attachment 132009 [details]
Output from cat /proc/net/wireless with the plugin NOT working
Comment 11 Alec Edworthy 2006-07-06 12:06:48 EDT
I've attached two files. These are outputs from /proc/net/wireless under two
different kernels, one where the plugin works and one where it doesn't. I've
noticed that there are major differences to the data regarding the level and
noise. iwconfig seems to report dB values under 2.6.16-1.2133_FC5 even though
/proc/net/wireless isn't.

Anyone got any ideas?

Thanks, Alec
Comment 12 Christoph Wickert 2006-07-13 19:42:48 EDT
Sorry for replying so late & thanks for your work, Alec. I'm pretty busy ATM but
I will look at this ASAP. Can you give me the iwconfig output, too?
Comment 13 Alec Edworthy 2006-07-14 04:27:02 EDT
Created attachment 132412 [details]
output from iwconfig under a kernel where the plugin works
Comment 14 Alec Edworthy 2006-07-14 04:28:34 EDT
Created attachment 132413 [details]
output from iwconfig (stdout and stderr) under a kernel where the plugin does NOT work
Comment 15 Alec Edworthy 2006-07-14 04:33:40 EDT
Two more files attached to the bug as requested. Please let me know if there is
anything else I can do. I've had a quick look at the code but at the moment I'm
having a couple of problems getting plugins for xfce4 to compile (it is barfing
when including wireless.h on my system for some reason, more investigation
required I think...).

Thanks again, Alec
Comment 16 Alec Edworthy 2006-10-18 03:11:16 EDT
Just to mention... I am not using the RT2500 driver, I have an Intel Centrino
built-in card and am using the IPW2200 driver but still experiencing the same
problems so this is not specific to the RT2500 driver.

Thanks, Alec
Comment 17 Alec Edworthy 2006-10-18 03:18:02 EDT
Created attachment 138762 [details]
iwconfig output under 2.6.18-1.2200.fc5 where the plugin does not work
Comment 18 Alec Edworthy 2006-10-18 03:19:16 EDT
Created attachment 138763 [details]
Contents of /proc/net/wireless under 2.6.18-1.2200.fc5 where the plugin does not work
Comment 19 Nicolas Chauvet (kwizart) 2006-10-18 08:03:28 EDT
When including the wireless.h do you pick the %{_includedir}/linux version or
the kernel version ?
Comment 20 Christoph Wickert 2006-10-18 10:22:52 EDT
(In reply to comment #19)
> When including the wireless.h do you pick the %{_includedir}/linux version or
> the kernel version ?

It's picking up %{_includedir}/linux. You think I should try to include the one
from the kernel?
Comment 21 Nicolas Chauvet (kwizart) 2006-10-18 11:03:41 EDT
I say that because it is similar to this case study with RuilT (a tool to
configure Ralink wireless devices )
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=202521

I think normal distribution package should link to this file
%{_includedir}/linux . But the problem to link to kernel-devel (and witch one)
package is that your package became some kind of kernel external module...(I'm
not sure it cross the line thought) - It seems to me a clean way to have updated
wireless.h include. Your package will then requires >= kernel which you used -
or which used same version of wireless.h . But this is not strict:
The reason is Wireless Extension are compatible back and forward (since version
16). 
So the bug may be because of used of a WE function v20 that is not present in WE
version 19 ( the RATE function is one of these )

The last thing is too have updated wireless-tools (now compiled in fedora core 5
with WE v19) - But because this package is at the base of the whole (wireless)
network part of the distribution (networkmanager use it) it seems difficult to
update easily (need mock) - which in this case it is better to upgrade to FC6...
( and expect fc6 bundle %{_includedir}/linux/wireless.h compatible to WE v20 )




Comment 22 Christoph Wickert 2007-06-20 07:11:04 EDT
Just for the record. This was fixed in wavelan-plugin 0.5.3, which is available
since Oct 5th, 2006. Unfortunately I cannot offer a solution for FC5, because
XFCE 4.2.x is no longer in development and I'm not going rebuild this package
against  wireless.h from kernel-devel.

I'm upgrading this bug to FC6 now and then close it CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.