This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 196650 - mount -t smbfs not supported / cifs error 5
mount -t smbfs not supported / cifs error 5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 04:42 EDT by Peter Pramberger
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-16 00:03:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Pramberger 2006-06-26 04:42:44 EDT
Description of problem:

Since upgrade to kernel 2.6.17-1.2139_FC4 I'm no longer able to mount a remote
samba share from a Solaris server running samba 2.0.7.

Version-Release number of selected component (if applicable):
kernel(-smp)?-2.6.17-1.2139_FC4
samba-client-3.0.14a-2

How reproducible:
Requires a UNIX system offering a share (using samba 2.0.x?)

Steps to Reproduce:
1. mount -t smbfs -o ro,guest //Tunix/PCHome /mnt/tunix
ERROR: smbfs filesystem not supported by the kernel
Please refer to the smbmnt(8) manual page
smbmnt failed: 255

2. mount -t cifs -o ro,guest //Tunix/PCHome /mnt/tunix
mount error 5 = Input/output error
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
  
Actual results:
smbfs is not included anymoure in the kernel and cifs aborts with error 5
(Input/output error).

Expected results:
The mount will succeed as with previous kernels.
Comment 1 Dave Jones 2006-06-26 10:46:39 EDT
fixed in cvs, will be back in next update.
Comment 2 Peter Pramberger 2006-07-07 09:11:50 EDT
Confirmed, smbfs is back in 2.6.17-1.2141_FC4.

Thx,
Peter
Comment 3 Nerijus Baliūnas 2006-07-14 17:22:41 EDT
smbfs is not supported in latest FC5 kernel (2.6.17-1.2145_FC5). Is it not
included in FC5 anymore? I cannot mount Win98 shares with cifs.
Comment 4 Dave Jones 2006-07-16 00:03:13 EDT
no, its intentionally dropped in fc5, due to lack of upstream maintenence.
if it doesn't work, file bugs.

Note You need to log in before you can comment on or make changes to this bug.