Bug 19667 - rpm -qi does not show installed package architecture (e.g., i686)
Summary: rpm -qi does not show installed package architecture (e.g., i686)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-24 04:38 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 11:24:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-24 04:38:15 UTC
"rpm -qi package" gives no indication of the architecture
for which the installed package was built.  To see this, try:

rpm -qi glibc

and examine the output.  Nowhere will you be able to see
whether the installed package was *.i386.rpm or *.i686.rpm,
for example.

Granted, you can find this information via:

rpm -q --queryformat='%{ARCH}+AFw-n' glibc

but it ought to be shown by default in the general info listing.

Comment 1 Jeff Johnson 2000-12-30 19:44:46 UTC
Query the arch tag, or, if you wish, edit /usr/lib/rpm/rpmpopt-* to add a query
for the arch tag
to the popt alias that actually implements --info.
I'm unwilling to make the change in the "default" configuration because
  a) rpm -qi already exists with well defined output
  b) most users don't need to see the arch tag because ...
  c) ... most packages do not benefit in any material (i.e. no significant
performance gain) way from         changing arch  because ...
  d) ... what is really desired is to know the optflags used to compile the
package. Try looking for
      RPMTAG_OPTFLAGS rather than RPMTAG_ARCH.


Note You need to log in before you can comment on or make changes to this bug.