Bug 196686 - Bug in Add/Remove Software in Fedora FC5
Bug in Add/Remove Software in Fedora FC5
Status: CLOSED DUPLICATE of bug 191630
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 10:23 EDT by Akb
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 10:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akb 2006-06-26 10:23:27 EDT
Component: Software Manager
Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType'
object has no attribute 'add_option'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 363, in ?
    main()
  File "/usr/sbin/pirut", line 358, in main
    pm = PackageManager()
  File "/usr/sbin/pirut", line 56, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
    self.doPluginSetup(types=(yum.plugins.TYPE_CORE))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 173, in
doPluginSetup
    optparser, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 148, in __init__
    self.run('config')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 26, in config_hook
    parser.add_option('', '--downloadonly', dest='dlonly', action='store_true',
AttributeError: 'NoneType' object has no attribute 'add_option'

Local variables in innermost frame:
conduit: <yum.plugins.ConfigPluginConduit instance at 0xb7947b0c>
parser: None
Comment 1 Jeremy Katz 2006-06-26 10:40:12 EDT

*** This bug has been marked as a duplicate of 191630 ***

Note You need to log in before you can comment on or make changes to this bug.