Bug 196705 - anaconda complains with "unknown error" during VNC install
anaconda complains with "unknown error" during VNC install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 11:49 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 10:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log from VNC install (46.42 KB, text/plain)
2006-06-27 14:22 EDT, Doug Chapman
no flags Details
anaconda.syslog from VNC install (53.82 KB, text/plain)
2006-06-27 14:23 EDT, Doug Chapman
no flags Details

  None (edit)
Description Doug Chapman 2006-06-26 11:49:42 EDT
Description of problem:
Seen doing a VNC install of rawhide-20060626 on an HP Integrity rx2620.  Install
went as normal then during the "perfoming post install configuration" a new
window pops up saying "Unknown error".  Clicking "close" allows anaconda to
continue on.

Not sure how to get more details on this.  I would be happy to gather any data
if you guys can point me to what is needed.


Version-Release number of selected component (if applicable):
rawhide-20060626
anaconda-11.1.0.48-1


How reproducible:
2 out of 2 tries on my rx2620, will try other systems.

Steps to Reproduce:
1. VNC install

  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2006-06-26 12:28:55 EDT
changing the summary since anaconda doesn't actually die here, it just complains.
Comment 2 Chris Lumens 2006-06-27 13:06:13 EDT
Please attach your /var/log/anaconda* from the installed system to this bug report.
Comment 3 Doug Chapman 2006-06-27 14:22:39 EDT
Created attachment 131622 [details]
anaconda.log from VNC install
Comment 4 Doug Chapman 2006-06-27 14:23:35 EDT
Created attachment 131623 [details]
anaconda.syslog from VNC install
Comment 5 Doug Chapman 2006-06-27 14:24:45 EDT
I have attached the requested logs.  Let me know if there is any other data I
can grab that would be helpful.
Comment 6 Doug Chapman 2006-06-27 15:12:11 EDT
tail of /tmp/anaconda.log when the error pops up:

15:07:19 WARNING : no dev package, going to bind mount /dev
15:07:19 DEBUG   : isys.py:mount()- going to mount /dev on /mnt/sysimage/dev
15:07:19 INFO    : self.hostname = localhost.localdomain
15:07:19 INFO    : moving (1) to step installpackages
15:07:19 INFO    : Preparing to install packages
15:08:45 INFO    : Initial install time estimate = 10.5844723853
15:18:14 INFO    : Actual install time = 10.0165082494
15:18:15 INFO    : moving (1) to step postinstallconfig
15:18:15 INFO    : moving (1) to step writeconfig
15:18:15 INFO    : Writing main configuration


tail of /mnt/sysimage/root/install.log when error pops up:
Installing xorg-x11-drv-magellan - 1.1.0-1.ia64
Installing xorg-x11-drv-dynapro - 1.1.0-1.ia64
Installing xorg-x11-drv-i810 - 1.6.0-5.ia64
Installing xorg-x11-drivers - 7.1-1.ia64
Installing gnome-applets - 1:2.15.1.1-2.ia64
Installing sound-juicer - 2.15.3-2.ia64
Installing rhythmbox - 0.9.5-1.ia64
Installing firstboot - 1.4.12-1.noarch
Installing gnome-session - 2.15.1-5.ia64
Installing linuxwacom - 0.7.4_1-2.ia64

Comment 7 Doug Chapman 2006-06-27 17:52:17 EDT
Appears to be related to writing /etc/shadow.  Once the system reboots there is
no /etc/shadow file and the encrypted password is in /etc/password as if shadow
passwords were not enabled.

I don't have a system handy that was installed in interactive text mode (I do
not see the error at all in text mode) but I did confirm on a system that was
installed via kickstart that /etc/shadow was created properly.
Comment 8 Chris Lumens 2006-06-29 14:39:43 EDT
From IRC (pasting here so I don't forget):

17:08 <dchapman_nashua> by the way, I just did a text mode install and verified
that /etc/shadow IS created properly
17:09 <dchapman_nashua> all the options I used were identical to the VNC install
where I got the "Unknown error" and it did not create /etc/shadow
Comment 9 Chris Lumens 2006-07-11 10:31:33 EDT
And just as mysteriously as this bug appeared, it is now gone.  Fixed in today's
Rawhide tree.
Comment 10 Chris Lumens 2006-07-12 17:54:33 EDT
Fixed it for real this time.  /usr/bin/authconfig -> /usr/sbin/authconfig.

Note You need to log in before you can comment on or make changes to this bug.