Bug 196708 - Detect Sound Card but No sound played
Detect Sound Card but No sound played
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-soundcard (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 12:07 EDT by Jae-Mun Choi
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 04:19:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jae-Mun Choi 2006-06-26 12:07:24 EDT
Description of problem:
After I did up2date few days ago, Video and Sound was disabled. I fixed Video
problem by re-installing driver and aticonfig. but still I am struggling with
soundcard problem. it detect like
[phytasea@bcm148-27 ~]$ lspci -v
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT
Express Memory Controller Hub (rev 03)
        Subsystem: Dell Unknown device 01cd
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>

00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT
Express PCI Express Root Port (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000e000-0000efff
        Memory behind bridge: dfd00000-dfefffff
        Prefetchable memory behind bridge: 00000000c0000000-00000000cff00000
        Capabilities: <access denied>

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
        Subsystem: Dell Unknown device 01cd
        Flags: bus master, fast devsel, latency 0, IRQ 177
        Memory at dfffc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>

00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=0b, subordinate=0b, sec-latency=0
        Capabilities: <access denied>

00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=0c, subordinate=0c, sec-latency=0
        Memory behind bridge: dfc00000-dfcfffff
        Capabilities: <access denied>

00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=0d, subordinate=0e, sec-latency=0
        I/O behind bridge: 0000d000-0000dfff
        Memory behind bridge: dfa00000-dfbfffff
        Prefetchable memory behind bridge: 00000000d0000000-00000000d0100000
        Capabilities: <access denied>
but when I played sound using Soundcard Detection, No sound was played. but with
old kernel I can play sound. So how can I fix this problem. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jae-Mun Choi 2006-06-27 10:59:38 EDT
I fixed problem by re installing ALSA package(driver, library, tools). then
sounds working normal. maybe next RHEL update I have to do the same thing again.
Comment 2 Martin Stransky 2006-06-29 11:20:15 EDT
Has the update of alsa-lib and alsa-lib fixed your problem? Or did you
completely reinstall these packages?
Comment 3 Jae-Mun Choi 2006-06-29 18:41:28 EDT
I updated all three which include driver, libray and tools. now I have sound
back. wiered thing is I couldn't find any change on configuration file. but
volume controller got changed. it only contains 3; master, capture and input
mix.  but I had IE856(<-- not sure what it was) but there was something in
between master and input mix. 
Comment 4 Martin Stransky 2006-07-25 04:19:56 EDT
It's not a bug, volume controls are set by card driver.

Note You need to log in before you can comment on or make changes to this bug.