Bug 196711 - LC_COLLATE for cs (Czech) locale is buggy wrt. uppercase letters
LC_COLLATE for cs (Czech) locale is buggy wrt. uppercase letters
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 13:04 EDT by Jan "Yenya" Kasprzak
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 04:03:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2006-06-26 13:04:20 EDT
Description of problem:
LC_COLLATE for cs (Czech) locale is buggy wrt. uppercase letters, it incorrectly
sorts uppercase letters before lowercase ones.

Version-Release number of selected component (if applicable):
glibc-2.4-8

Steps to Reproduce:
1. LC_ALL=cs_CZ.UTF-8 sort <<EOF
jakub
Jakub
EOF
  
Actual results:

Jakub
jakub


Expected results:

jakub
Jakub

Additional info:
The Czech sorting algorithm should put lowercase letters first (when the sorted
words are otherwise the same except possible non-alphanumeric characters).

For more info about the Czech sorting, see Petr Olsak's article in the CSTUG
bulletin (in Czech).

http://math.feld.cvut.cz/ftp/olsak/bulletin/csr.ps

Or see the examples from Jan Pazdziora's Czech sorting page:

http://www.fi.muni.cz/~adelton/l10n/cssort/sort.tab

Except for the above error, I think the Czech locale provides correct sorting.

This behaviour is actually documented as known bug in
/usr/share/i18n/locales/cs_CZ (see the comment labeled "3.7").
Comment 1 Ulrich Drepper 2006-07-30 18:25:14 EDT
It's trivial to change but you have the get the last maintainer (Vladimir Michl)
to agree.  Only if he does or doesn't reply will I change the file.
Comment 2 Jan "Yenya" Kasprzak 2006-11-28 07:53:15 EST
Sorry for the delay - I have now tried to cotnact Vladimir Michl, and asked him
to add a note to this bug or contact you by email.
Comment 3 Vladimir Michl 2006-11-29 05:14:22 EST
Hello,

as I see Yenya is right. And I think we should change it as he requests.
Just after change, so lowercase letters are before uppercase, can we delete
point 3.7 at the start as well.

Thanks

Vladimir Michl
Comment 4 Ulrich Drepper 2007-09-30 14:45:26 EDT
Should be fixed in upstream cvs.
Comment 5 Jakub Jelinek 2007-10-04 04:03:25 EDT
In glibc-2.6.90-17 in rawhide, please test.
Comment 6 Jan "Yenya" Kasprzak 2007-10-05 08:44:04 EDT
Works for me, thanks!

Note You need to log in before you can comment on or make changes to this bug.