Bug 196759 - ENOMEM after a number of snapshots
ENOMEM after a number of snapshots
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Milan Broz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-26 18:29 EDT by Issue Tracker
Modified: 2013-02-28 23:04 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:14:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2006-06-26 18:29:37 EDT
Escalated to Bugzilla from IssueTracker
Comment 7 Issue Tracker 2006-06-26 18:30:32 EDT
This error still appears to exist in RHEL 4 U3 

/usr/sbin/lvcreate -L 1G -p r -s -n golive-20060613152756
/dev/svg/golivelv
  device-mapper: reload ioctl failed: Cannot allocate memory
  Failed to suspend origin golivelv




Any idea how to fix this?  I get it after creating about 25 snapshots on 25
different file systems. 

I'm marking this as high because if we can't get an answer to this by
June 20th, I'll be forced to scrap LVM and start testing Veritas again.




Severity set to: High

This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 79915
Comment 10 Issue Tracker 2006-06-26 18:30:42 EDT
It looks like BZ 164959 fixed the cases were snapshot was causing the
system to hang or crash. Basically, the steps to create or activate a
snapshot have been resequenced so that memory gets reserved before the
snapshot becomes live. In this case, it looks like there is not enough
memory to create the snapshot.

First, I would recommend testing with the latest RHEL4 U4 test kernel, I
don't see this specific problem fixed; though, there have been several
fixes to the device-mapper code. Second, tune
/proc/sys/vm/overcommit_memory, please change this value from 0 to 1.


Internal Status set to 'Waiting on Support'

This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 79915
Comment 12 Issue Tracker 2006-06-26 18:30:50 EDT
The beta kernel did the same exact thing.


/usr/sbin/lvcreate -L 1G -p r -s -n perpet-20060620112952
/dev/svg/perpetlv
  device-mapper: reload ioctl failed: Cannot allocate memory
  Failed to suspend origin perpetlv


 uname -a
Linux testwms 2.6.9-39.ELhugemem #1 SMP Thu Jun 1 18:12:08 EDT 2006 i686
i686 i386 GNU/Linux





This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 79915
Comment 13 Issue Tracker 2006-06-26 18:30:54 EDT
Attached is an strace of the lvcreate command.  

Line 7493 is where the memory allocation error comes from

ioctl(3, DM_TABLE_LOAD, 0x87538d8)      = -1 ENOMEM (Cannot allocate
memory)


This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 79915
Comment 16 Issue Tracker 2006-06-26 18:31:26 EDT
Yes, I set it yesterday in my testing and it didn't change the behavior at
all.  Still failed on the 33th snapshot I tried to create.


This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 79915
Comment 23 Issue Tracker 2006-06-26 18:32:05 EDT
This problem originates in dm_table_create() -> alloc_targets() ->
dm_valloc() -> vmalloc() to allocate virtual contiguous memory. The same
bug (BZ 191531) has been filed against FC4, it looks like it is a
limitation of the system; but, I wasn't sure if Alasdair considered this a
bug.

Internal Status set to 'Waiting on Engineering'

This event sent from IssueTracker by dmilburn  [Support Engineering Group]
 issue 79915
Comment 26 David Milburn 2006-07-24 11:59:16 EDT
Alasdair, can you comment on this problem? Thanks.
Comment 27 RHEL Product and Program Management 2006-08-18 11:20:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 36 Issue Tracker 2007-06-26 13:13:55 EDT
Kelly,

I got confirmation that this is in RHEL4.6.  Going to close this ticket.


Internal Status set to 'Resolved'
Status set to: Closed by Tech
Resolution set to: 'RHEL 4.6'
Ticket type set to: 'Problem'

This event sent from IssueTracker by klamb@redhat.com 
 issue 79915
Comment 37 Jason Baron 2007-07-03 18:37:45 EDT
committed in stream U6 build 55.16. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 41 errata-xmlrpc 2007-11-15 11:14:25 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.