Bug 19679 - Kickstart install fails on long partition names
Kickstart install fails on long partition names
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-24 09:07 EDT by Bill Woodward
Modified: 2007-03-26 23:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 16:18:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Woodward 2000-10-24 09:07:01 EDT
I am using the kickstart installation method to install a RedHat 7 system
via NFS, and when I specify a long pathname for the 'part' command, the
system installs, but on reboot fails to mount that partition.

I believe that this is exactly the problem described in Bug ID 17900, but
that fix was made to the update diskette image.  Because I'm doing a
kickstart install, I need it in the bootnet.img as well.  Also, at some
point, I anticipate needing to make a CD-ROM with the same set of RPMs I'm
currently installing via nfs, so I need a boot.img as well.

Here's my ks.cfg file.  Changing the '/home/dazel/jobs' line (16
characters) to '/home/dazel/var' (15 characters) causes everything to work
fine.

-----
#########################################################
#
# Kickstart commands section
#
auth

# Be very! very! careful with this!!!

lang en_US
keyboard us
mouse

network --bootproto static --ip 15.23.56.28 --gateway 15.23.56.1
--nameserver 15.23.62.6 --netmask 255.255.255.0
nfs --server kzinti.build.austin.hp.com --dir /build/RHL

zerombr yes
clearpart --all
part /boot --size 20
part swap --size 128
part / --size 1024 
part /var --size 1024
part /home --size 1000
part /home/dazel/jobs --size 500 --grow
install

lilo
rootpw genesis
timezone America/Chicago

#########################################################
#
# Packages
#

%packages
@ Base
@ Network Server
@ Web Server
@ Utilities
dazelos
dazeldfr3
jre
ApacheJServ
HPDR-webui
HPDR-config
HPDR-dwd

#########################################################
#
# Post installation, currently nothing
#

%post
# add comment to /etc/motd
echo "HP Document Router installed `/bin/date`" > /etc/motd

# add the dazel user
adduser dazel

# small router, so install the small ServerList file
cp /home/dazel/etc/ServerList.small /home/dazel/etc/ServerList
-----
Comment 1 Michael Fulbright 2000-10-30 16:18:25 EST
You can use the update disk with your kickstart install.

Just run the command at the syslinux boot prompt:

  linux ks updates

It will prompt you to insert the update disk at the appropriate time.


Note You need to log in before you can comment on or make changes to this bug.