Bug 196858 - Small typo makes User Logins impossible to match for ftpd-messages filter.
Summary: Small typo makes User Logins impossible to match for ftpd-messages filter.
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: logwatch (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-27 11:41 UTC by Friedrich Clausen
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 10:03:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes typo "$Details" to "$Detail" (688 bytes, patch)
2006-06-27 11:41 UTC, Friedrich Clausen
no flags Details | Diff

Description Friedrich Clausen 2006-06-27 11:41:04 UTC
Description of problem:

Logwatch will never match ftpd user login entries. This is due to a mis-named
variable "$Details" (instead of "$Detail") in the UserLogin matching if
statement of the ftpd-messages filter.

Version-Release number of selected component (if applicable):

logwatch-4.3.2-2

How reproducible:

If you generate matchable FTP user login logging through ftpd then logwatch will
never match.

Steps to Reproduce:
1. Start ftpd
2. Login a few times
3. Run logwatch (eg. logwatch --print --range Today)
  
Actual results:

--------------------- ftpd-messages Begin ------------------------

**Unmatched Entries**
Sep 20 23:08:39 ftp-server ftpd[5828]: FTP LOGIN FROM host1 as user1
Sep 20 23:09:38 ftp-server ftpd[5828]: FTP LOGIN FROM host1 as user1
Sep 20 23:18:18 ftp-server ftpd[5872]: FTP LOGIN FROM host1 as user1
Sep 20 23:19:33 ftp-server ftpd[5872]: FTP LOGIN FROM host1 as user1

---------------------- ftpd-messages End -------------------------

Expected results:

--------------------- ftpd-messages Begin ------------------------

User FTP Logins:
   host1 (10.1.1.3): as user1 - 4 Time(s)

---------------------- ftpd-messages End -------------------------

Additional info:

Note that I had to simulate the log entries as RHEL 3 does not come with a plain
ftpd. It makes the attached patch a bit moot but I found the bug while working
on the patch for bug 196856. I hope it is of use.

Comment 1 Friedrich Clausen 2006-06-27 11:41:04 UTC
Created attachment 131595 [details]
Fixes typo "$Details" to "$Detail"

Comment 2 Ivana Varekova 2006-10-30 10:03:33 UTC
This problem will be resolved in a future major release of Red Hat Enterprise
Linux. Red Hat does not currently plan to provide a resolution for this in a Red
Hat Enterprise Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects. 


Note You need to log in before you can comment on or make changes to this bug.