Bug 196895 - undefined symbol: g_type_register_static_simple
Summary: undefined symbol: g_type_register_static_simple
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evince   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
: 192928 197200 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-27 15:27 UTC by Bob T.
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 20:46:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bob T. 2006-06-27 15:27:27 UTC
Description of problem:
execution produces undefined symbol: g_type_register_static_simple

build of src.rpm produces libpoppler-glib.so: undefined reference to
`g_type_register_static_simple'

Version-Release number of selected component (if applicable):

evince-0.5.3
poppler-devel-0.5.3-1
poppler-0.5.3-1
poppler-utils-0.5.3-1

(on a FC-5 system)


How reproducible:


Steps to Reproduce:
1. call evince 
or rpmbuild -bb evince.spec
2.
3.
  
Actual results: As above


Expected results:
Normal execution or package build.


Additional info:

Comment 1 Bob T. 2006-06-29 00:53:03 UTC
This problem went away when I upgraded glib2 from 2.10.3-1 to 2.11.4-1. Please
fix the package dependencies.

Comment 2 Kristian Høgsberg 2006-06-29 20:44:59 UTC
*** Bug 197200 has been marked as a duplicate of this bug. ***

Comment 3 Kristian Høgsberg 2006-06-29 20:46:01 UTC
Done, closing bug.

Comment 4 Kristian Høgsberg 2006-06-29 21:13:40 UTC
*** Bug 192928 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.