Bug 196966 - conman: useless debuginfo package
conman: useless debuginfo package
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: conman (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 16:54 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.1.9.2-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 14:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-06-27 16:54:32 EDT
conman produces a useless debuginfo package:

$ rpm -qlp
http://fedoraproject.org/extras/development/i386/debug/conman-debuginfo-0.1.9.1-3.fc6.i386.rpm
(contains no files)

0.1.9.2 seems to have the same issue, caused by "install -s" invoked by make
install.  More info: http://fedoraproject.org/wiki/Packaging/Debuginfo
Comment 1 Jarod Wilson 2006-06-27 17:10:44 EDT
Will be fixed in next build, thanks for catching it.

$ rpm -qplv /build/RPMS/x86_64/conman-debuginfo-0.1.9.2-2.x86_64.rpm
-rwxr-xr-x    1 root    root           104936 Jun 27 17:16
/usr/lib/debug/usr/bin/conman.debug
-rwxr-xr-x    1 root    root           192088 Jun 27 17:16
/usr/lib/debug/usr/sbin/conmand.debug
Comment 2 Ville Skyttä 2006-06-27 17:36:51 EDT
Hmm, curious, debuginfo packages used to contain the respective source files in
/usr/src/debug in addition to *.debug in /usr/lib/debug.  Any ideas why they're
not included here?
Comment 3 Jarod Wilson 2006-06-27 17:46:28 EDT
Hrm, the above was from an FC5 build, which I don't believe pulls in all the
sources. However, I just did a devel build, and I'm not seeing anything but the
.debug files. Ugh. I'll reopen and investigate some more...
Comment 4 Jarod Wilson 2006-06-27 17:48:18 EDT
I take it back, FC5 does pull in the sources. Not my day...
Comment 5 Jarod Wilson 2006-09-20 14:06:02 EDT
Okay, it looks like something on my system is interfering with find-debuginfo.sh
doing its thing, as packages built under my account wind up without source
files, but if built in mock, everything is fine, package contains all the
expected source files, etc. Closing bug, its only my system that's busted
somehow. :) (though I'm still going to try to root-cause that)

Note You need to log in before you can comment on or make changes to this bug.