Bug 19698 - Error in rc script for vncserver
Summary: Error in rc script for vncserver
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: vnc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-24 17:12 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-26 12:52:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is a patch to fix this. Unfortunately, now that it _works_, 'service vncserver stop' will kill all Xvnc processes. :-( (818 bytes, patch)
2000-10-26 12:52 UTC, Tim Waugh
no flags Details | Diff

Description Need Real Name 2000-10-24 17:12:17 UTC
The script that starts vnc-server makes a call to another script that does
the actual executing of VNC.  However, this script spawns a child process
that is the vnc server.  Because the name of the executable
changes.pidlist=`pidofproc $1`
Example:
(from /etc/init.d/functions)
<snip>
        # Save basename.
        base=`basename $1`

        # Find pid.
        pid=
        for apid in $pidlist ; do
           [ -d /proc/$apid ] && pid="$pid $apid"
        done
</snip>

The basename of /usr/bin/vncserver is vncserver, while the actual
executable is Xvnc.  Note that Xvnc isn't the client (thats vncviewer). 
The only implication I've seen so far is that while trying to query the
status of vncserver or kill/restart it, the script fails, not only not
returning the status, but not killing the server.  If the server has an
another attempt to start before a reboot or manual removal of the Xvnc
process, the new instances cannot grab the default :0 or :1 addresses and
therefore may lead to confusion as to which Xvnc session is being accessed.

-Ben Klang, KF4WBX
ben@insightsys.com

Comment 1 Tim Waugh 2000-10-26 12:52:04 UTC
Created attachment 4674 [details]
Here is a patch to fix this.  Unfortunately, now that it _works_, 'service vncserver stop' will kill all Xvnc processes. :-(

Comment 2 Tim Waugh 2000-10-26 13:36:37 UTC
I've put this patch in vnc-3.3.3r1-12.


Note You need to log in before you can comment on or make changes to this bug.