Bug 196982 - something broke between FC4 and FC5?
something broke between FC4 and FC5?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 18:34 EDT by james
Modified: 2008-01-10 08:11 EST (History)
0 users

See Also:
Fixed In Version: 8.61-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 08:11:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Document1.ps (24.36 KB, text/plain)
2006-12-15 11:22 EST, Tim Waugh
no flags Details

  None (edit)
Description james 2006-06-27 18:34:00 EDT
Description of problem:
Hmm - this latest version of ghostscript can no longer read
WordPerfect8-generated postscript files which were generated after around the
summer of 2004.  These later files most noticeably now have the top line
"12345X@PJL ENTER LANGUAGE = POSTSCRIPT".  Everything was working fine on FC4.

Version-Release number of selected component (if applicable):
ghostscript-8.15.2-1.1

How reproducible:
Every time.

Steps to Reproduce:
1. gv <file> or lpr <file>
2.
3.
  
Actual results:
ESP Ghostscript 815.02: Unrecoverable error, exit code 1


Expected results:


Additional info:
These newly-become problem postscipt files were all generated with WordPerfect
8.  Other files, mostly graphic image postscript files, and postscipt recently
generated from pdf, still seem to work normally.  A "problem-file" is attached.
Comment 1 Tim Waugh 2006-06-28 03:22:20 EDT
This sounds like a PJL-encapsulated PostScript job, so perhaps something like
this is what's needed:

http://www.rz.uni-karlsruhe.de/~andy/source/Local/pjlstrip-1.0/pjlstrip.c

I didn't think that ghostscript intentionally stripped PJL before.  Could you
attach the file in question please?  Thanks.
Comment 2 james 2006-07-28 15:46:23 EDT
Did you get the test file I sent?

This is still a problem for me since I have to print reports every month with WP.
Comment 3 Tim Waugh 2006-12-15 10:32:26 EST
No, there is no attachment to this bug report.
Comment 4 Tim Waugh 2006-12-15 11:22:05 EST
Created attachment 143781 [details]
Document1.ps

[sent by email]
Comment 6 Espen Stefansen 2007-04-26 13:28:42 EDT
I just had a look at this and it seems that it's the line containing 
setpagedevice and PreferredMediaSelection that fails. 

If u remove "PreferredMediaSelection true" from line 392, the document is 
working.
Comment 7 james 2007-04-26 14:34:27 EDT
Yes!  Thanks for looking at that.  That difference seems to be consistent 
across other working and non-working postscript files I have.

There are two WordPerfect files which contain that term - err, which is 
not "PreferredMediaSelection", but correctly "DeferredMediaSelection":
 shlib10/hpla4pps.prs
 shlib10/wp60ps01.us.all

This was not a change between FC4 and FC5, but instead, my starting to use an 
HP LaserJet 4 Plus around that time, which apparently makes use of the 
shlib10/hpla4pps.prs file.

The remaining question would be: Is there anything wrong with the way 
ghostscript is interpreting that line, or is that line invalid postscript from 
WordPerfect?
Comment 8 Tim Waugh 2008-01-10 08:11:55 EST
This seems to work fine now in Fedora 8 (ghostscript-8.61-5.fc8).

Note You need to log in before you can comment on or make changes to this bug.