Bug 197015 - New cogito package required to match git-core-1.4.0
New cogito package required to match git-core-1.4.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cogito (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 22:02 EDT by Malcolm Tredinnick
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-28 13:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Malcolm Tredinnick 2006-06-27 22:02:44 EDT
Description of problem:
Recent upgrade of git-core package (to 1.4.0-1.fc5) means that cg-status no
longer works.

Version-Release number of selected component (if applicable):
0.71.2-1.fc5

How reproducible:
Always

Steps to Reproduce:
1.Run cg-status against any valid git repository
  
Actual results:

After information about the repo ids is printed, we get this error message:

fatal: ambiguous argument '': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions

This is due to a change in git-diff in the interim. Upstream cogito has been
fixed to handle this. It just needs a new package.
Expected results:


Additional info:
Comment 1 Chris Wright 2006-06-28 13:34:45 EDT
Thanks, new cogito-0.17.3 package built.  Should propagate out soon.

Note You need to log in before you can comment on or make changes to this bug.