Bug 197026 - df lists two different filesystem devices under the same name
df lists two different filesystem devices under the same name
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 01:44 EDT by Craig Pemberton
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 23:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Pemberton 2006-06-28 01:44:30 EDT
Description of problem: df lists two different filesystem devices under the same
name

Version-Release number of selected component (if applicable):

[~]rpm -qf `which df`
coreutils-5.96-1.2

How reproducible:

df

Steps to Reproduce:
I'm not sure! I've been running this setup for a while, with identical fstabs in
both /dev/hda5 and /dev/hda3. I switch back and forth using grub. Sometimes I
reinstall my /dev/hda3 fedora installation.

Actual results:

[~]df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1             30470176  19814084   9083332  69% /
tmpfs                   257896         0    257896   0% /dev/shm
/dev/hda3             30470176  19814084   9083332  69% /mnt/UNION
/dev/hda5            118000672 109384416   8616256  93% /mnt/BASALM
/dev/hda1             28439328  22076988   4894404  82% /mnt/MAIN
[~]df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1             30470176  21361656   7535760  74% /
tmpfs                   257896         0    257896   0% /dev/shm
/dev/hda3             30470176  21361656   7535760  74% /mnt/UNION
/dev/hda5            118000672 109384416   8616256  93% /mnt/BASALM
/dev/hda1             28439328  20642680   6328712  77% /mnt/MAIN
[~]df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1             30470176  21413416   7484000  75% /
tmpfs                   257896         0    257896   0% /dev/shm
/dev/hda3             30470176  21413416   7484000  75% /mnt/UNION
/dev/hda5            118000672 109384416   8616256  93% /mnt/BASALM
/dev/hda1             28439328  20642680   6328712  77% /mnt/MAIN
[~]df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1             30470176  24427224   4470192  85% /
tmpfs                   257896         0    257896   0% /dev/shm
/dev/hda3             30470176  24427224   4470192  85% /mnt/UNION
/dev/hda5            118000672 109384416   8616256  93% /mnt/BASALM
/dev/hda1             28439328  17584932   9386460  66% /mnt/MAIN
[~]cat /etc/fstab
LABEL=/1                /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-hda2         swap                    swap    defaults        0 0
#/dev/hda3              /mnt/UNION              ext3    defaults        0 0
/dev/hda5               /mnt/BASALM             vfat    defaults        0 0
/dev/hda1               /mnt/MAIN               ext3    defaults        0 0
[~]umount /mnt/UNION
[~]df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1             30470176  24427492   4469924  85% /
tmpfs                   257896         0    257896   0% /dev/shm
/dev/hda5            118000672 109384416   8616256  93% /mnt/BASALM
/dev/hda1             28439328  17584932   9386460  66% /mnt/MAIN

I edited my fstab and rebooted to no avail:

[~]cat /etc/fstab
LABEL=/1                /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
LABEL=SWAP-hda2         swap                    swap    defaults        0 0
#/dev/hda3              /mnt/UNION              ext3    defaults        0 0
/dev/hda5               /mnt/BASALM             vfat    defaults        0 0
/dev/hda1               /mnt/MAIN               ext3    defaults        0 0
[~]df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1             30470176  24426136   4471280  85% /
tmpfs                   257896         0    257896   0% /dev/shm
/dev/hda5            118000672 109384416   8616256  93% /mnt/BASALM
/dev/hda1             28439328  17585084   9386308  66% /mnt/MAIN


Expected results:

The first filesystem should be named /dev/hda3

Additional info:
Comment 1 Craig Pemberton 2006-06-28 02:09:04 EDT
The following seems to show that df is not at fault. I have no clue what is
happening here.

[~]mount
/dev/hda1 on / type ext3 (rw)
. . . 
/dev/hda1 on /mnt/lfs type ext2 (rw)
Comment 2 Dave Jones 2006-07-25 23:12:40 EDT
looks like hda1 has the label '/1'.
AFAICS, there's no bug here, you asked it to be mounted at / and /mnt/MAIN, and
it did.

Note You need to log in before you can comment on or make changes to this bug.