Bug 197058 - other language map chosen as default for bn_IN locale
other language map chosen as default for bn_IN locale
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
: 199105 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 07:44 EDT by Runa Bhattacharjee
Modified: 2013-03-03 21:20 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.4.4-31.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 21:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of as-inscript keymap layout activated by default on bengali India locale (227.45 KB, image/png)
2006-06-28 07:44 EDT, Runa Bhattacharjee
no flags Details

  None (edit)
Description Runa Bhattacharjee 2006-06-28 07:44:16 EDT
Description of problem:

The default scim keymap activated by pressing ctrl+space on the bn_IN locale is
as-inscript instead of bn-inscript.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select language Bengali (India) from gdm and login
2. Open Gedit
3. Press ctrl+space to activate scim

  
Actual results:

default input keymap is Assamese-inscript

Expected results:

default input keymap should be Bengali-inscript


Additional info:
attached image [bengali_INscim.png]
Comment 1 Runa Bhattacharjee 2006-06-28 07:44:16 EDT
Created attachment 131658 [details]
screenshot of as-inscript keymap layout activated by default on bengali India locale
Comment 2 Mayank Jain 2006-08-01 06:04:43 EDT
Adding 

/DefaultIMEngineFactory/bn_IN = IMEngine-M17N-bn-inscript

in the user's ~/.scim/config file rectifies this bug.

IMHO, this file is generated by scim & hence changing the component to SCIM.

Jensp, can you please comment?

Thanks,
Mayank
Comment 3 Mayank Jain 2006-08-01 06:12:54 EDT
Jensp, if its a scim bug, can you please re-assign it?
Thanks.
Comment 4 Jens Petersen 2006-08-01 06:57:50 EDT
*** Bug 199105 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2006-08-01 07:01:04 EDT
Most likely a scim or scim-m17n bug: at least a workaround is
available in scim per comment 2, though it shouldn't be necessary
to set the default for Bengali to inscript explicitly.
Comment 6 Jens Petersen 2006-08-01 07:28:47 EDT
Also happening for ml_IN according to bug 200876#c7.
Comment 7 Mayank Jain 2006-08-01 07:31:58 EDT
Jens, no...
thats a completely different bug.
200876 was that when i try to select ml-inscript from scim-panel, only english
gets selected on the scim-panel.
Comment 8 Mayank Jain 2006-08-01 07:33:24 EDT
But yes... the workaround is the same :)
Comment 9 Jens Petersen 2006-08-01 08:06:52 EDT
ml_IN was a false alarm apparently.
Comment 10 Jens Petersen 2006-08-09 10:24:01 EDT
Fix committed to cvs (scim_backup-default-engine-2letter-locale-197058.patch).

Also fixed Assamese default problem with scim_utility-Assamese-locale-fix.patch.
Comment 11 Jens Petersen 2006-08-09 10:48:38 EDT
(build pending on bug 201844 btw)
Comment 12 Mayank Jain 2006-08-10 02:34:44 EDT
Cool!

Note You need to log in before you can comment on or make changes to this bug.