Bug 197114 - new ipccreate interface for explicit ipc object labeling
new ipccreate interface for explicit ipc object labeling
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 13:02 EDT by Eric Paris
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 11:08:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rough draft patch (4.81 KB, patch)
2006-06-28 13:02 EDT, Eric Paris
no flags Details | Diff
Patch which should address this issue if a user ever wants it (5.37 KB, patch)
2006-08-04 12:21 EDT, Eric Paris
no flags Details | Diff

  None (edit)
Description Eric Paris 2006-06-28 13:02:49 EDT
Created attachment 131684 [details]
rough draft patch
Comment 1 Eric Paris 2006-06-28 13:02:49 EDT
New ipccreate interface to allow explicite labeling on ipc objects, like
msgqueues and semephores.
Comment 2 Eric Paris 2006-08-04 12:20:19 EDT
At this time this patch is going to be back burnered.  Currently there is no
userspace program clammoring to use this.  I talked with people working on
XSELinux and they may get to this, but since shm is not part of core X work it
will be some time before they work on the 'optional' portions.
Comment 3 Eric Paris 2006-08-04 12:21:38 EDT
Created attachment 133647 [details]
Patch which should address this issue if a user ever wants it
Comment 4 Eric Paris 2006-09-25 11:08:00 EDT
Closing won't fix for now, as no user has come to light to use this patch.

Note You need to log in before you can comment on or make changes to this bug.