Bug 197149 - Crash when selecting Scientific mode
Crash when selecting Scientific mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcalctool (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
https://testing.108.redhat.com/source...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 16:44 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 12:49:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 346145 None None None Never

  None (edit)
Description Dave Malcolm 2006-06-28 16:44:51 EDT
Description of problem:
gcalctool starts in Normal mode, and segfaults when selecting Scientific mode

Version-Release number of selected component (if applicable):
gcalctool-5.8.13-2

How reproducible:
100% so far

Steps to Reproduce:
1. Run the dogtail script at the attached URL.
  
Actual results:
Segfault:
Distribution: Fedora Core release 5.89 (Rawhide)
Gnome Release: 2.15.2 2006-05-17 (Red Hat, Inc)
BugBuddy Version: 2.15.0

Memmory status: size: 65486848 vsize: 0 resident: 65486848 share: 0 rss:
11882496 rss_rlim: 0
CPU usage: start_time: 1151527814 rtime: 0 utime: 62 stime: 0 cutime:40 cstime:
0 timeout: 22 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/gcalctool'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208764736 (LWP 4285)]
0x0027d402 in __kernel_vsyscall ()
#0  0x0027d402 in __kernel_vsyscall ()
#1  0x00d99bb3 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x0094ff26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x08064496 in matherr ()
#5  0x00dcc983 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
#6  0x00dbefdb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#7  0x00dd1285 in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#8  0x00dd26e3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#9  0x00dd2989 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#10 0x02712c55 in gtk_radio_action_new () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x00dcc809 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#12 0x00dbd809 in g_value_set_static_boxed ()
   from /usr/lib/libgobject-2.0.so.0
#13 0x00dbefdb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0x00dd170a in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#15 0x00dd26e3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#16 0x00dd2989 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0x025d77a5 in gtk_widget_get_action () from /usr/lib/libgtk-x11-2.0.so.0
#18 0x025d8668 in gtk_action_activate () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x00dcc809 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#20 0x00dbefdb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#21 0x00dd1285 in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#22 0x00dd26e3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#23 0x00dd2989 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#24 0x02803324 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#25 0x026e2b18 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#26 0x026e36bd in gtk_menu_shell_append () from /usr/lib/libgtk-x11-2.0.so.0
#27 0x00dcd6a3 in g_cclosure_marshal_VOID__BOOLEAN ()
   from /usr/lib/libgobject-2.0.so.0
#28 0x00dbd809 in g_value_set_static_boxed ()
   from /usr/lib/libgobject-2.0.so.0
#29 0x00dbefdb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#30 0x00dd18c3 in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
#31 0x00dd26e3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#32 0x00dd445e in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#33 0x009bba88 in gail_menu_item_new ()
   from /usr/lib/gtk-2.0/modules/libgail.so
#34 0x0012abc1 in g_list_remove_link () from /usr/lib/libglib-2.0.so.0
#35 0x0012c57d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0x0012f80f in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#37 0x0012fbb9 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#38 0x026cd0b4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#39 0x08064e97 in matherr ()
#40 0x00b205a4 in __libc_start_main () from /lib/libc.so.6
#41 0x0804d411 in ?? ()

Thread 1 (Thread -1208764736 (LWP 4285)):
#0  0x0027d402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00d99bb3 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0094ff26 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x08064496 in matherr ()
No symbol table info available.
#5  0x00dcc983 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#6  0x00dbefdb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#7  0x00dd1285 in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#8  0x00dd26e3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#9  0x00dd2989 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x02712c55 in gtk_radio_action_new () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#11 0x00dcc809 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#12 0x00dbd809 in g_value_set_static_boxed ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#13 0x00dbefdb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#14 0x00dd170a in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#15 0x00dd26e3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#16 0x00dd2989 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#17 0x025d77a5 in gtk_widget_get_action () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#18 0x025d8668 in gtk_action_activate () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#19 0x00dcc809 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#20 0x00dbefdb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#21 0x00dd1285 in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#22 0x00dd26e3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#23 0x00dd2989 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#24 0x02803324 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#25 0x026e2b18 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#26 0x026e36bd in gtk_menu_shell_append () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#27 0x00dcd6a3 in g_cclosure_marshal_VOID__BOOLEAN ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#28 0x00dbd809 in g_value_set_static_boxed ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#29 0x00dbefdb in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#30 0x00dd18c3 in g_signal_override_class_closure ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#31 0x00dd26e3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#32 0x00dd445e in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#33 0x009bba88 in gail_menu_item_new ()
   from /usr/lib/gtk-2.0/modules/libgail.so
No symbol table info available.
#34 0x0012abc1 in g_list_remove_link () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#35 0x0012c57d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#36 0x0012f80f in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#37 0x0012fbb9 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#38 0x026cd0b4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#39 0x08064e97 in matherr ()
No symbol table info available.
#40 0x00b205a4 in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#41 0x0804d411 in ?? ()
No symbol table info available.
Comment 1 Dave Malcolm 2006-06-29 17:30:21 EDT
Ray: the upstream maintainer that this is fixed in the latest tarball (see
upstream bug report) - is it worth pushing that tarball into rawhide for testing?
Comment 2 Dave Malcolm 2006-06-29 17:38:39 EDT
s/maintainer that/maintainer says that/
Comment 3 Matthias Clasen 2006-07-25 12:49:45 EDT
Seems to be fixed in 5.8.17 that is in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.