Bug 197157 - AMD Cool'n'Quiet: yum fails to install openoffice.org-calc on x86_64
AMD Cool'n'Quiet: yum fails to install openoffice.org-calc on x86_64
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 18:02 EDT by David Bowen
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Entries from /var/log/messages when the process crashed (3.19 KB, text/plain)
2006-06-28 18:02 EDT, David Bowen
no flags Details
Yum output when the process crashed (851 bytes, text/plain)
2006-06-28 18:03 EDT, David Bowen
no flags Details
Output of lshw (45.28 KB, text/html)
2006-10-16 19:12 EDT, David Bowen
no flags Details

  None (edit)
Description David Bowen 2006-06-28 18:02:18 EDT
Description of problem:

I recently purchased an AMD AM2 64 X2 4200+ based machine. I am unable to
install openoffice.org-calc using yum. Of course this may be to do with it being
the "i386" version from the repository.

Version-Release number of selected component (if applicable):

openoffice.org-calc     i386       1:2.0.2-5.12.2

How reproducible:

First time I tried it crashed the machine.

Then I changed the NIC and tried again. This time it said "Unable to handle
kernel NULL pointer dereference at 0000000000000000 RIP:" and some more in the
"messages.log" and "yum.log" attached.

The third time I tried it just hung on the install section:

  Installing: openoffice.org-core          ################          [1/2]  

Steps to Reproduce:
# yum install *office*calc*
  
Actual results:

Crashes machine, crashes the process or hangs the process.

Expected results:

openoffice.org-calc should be installed

Additional info:

To be honest quite a few things seem to be segfaulting but I really don't know why.

# uname -a
Linux somehost 2.6.17-1.2139_FC5 #1 SMP Fri Jun 23 12:40:11 EDT 2006 x86_64
x86_64 x86_64 GNU/Linux
Comment 1 David Bowen 2006-06-28 18:02:18 EDT
Created attachment 131702 [details]
Entries from /var/log/messages when the process crashed
Comment 2 David Bowen 2006-06-28 18:03:17 EDT
Created attachment 131703 [details]
Yum output when the process crashed
Comment 3 David Bowen 2006-06-28 19:13:37 EDT
I noticed a log entry from some other failed process that seemed to indicate it
was trying to set the host cpu clock speed and failing. So I went and set my
machine to have a fixed CPU speed in the BIOS (disabled AMD Cool'n'Quiet). This
change seems to have allowed me to execute the command and install
openoffice.org-calc. I can confirm that it also runs (rather more quickly than
on my old machine).

I can't see a way to update the bug title to include the phrase AMD Cool'n'Quiet.
Comment 4 Caolan McNamara 2006-06-29 02:38:26 EDT
Not a OOo problem, hardly a yum one either. Whether it's a kernel of
Cool'n'Quiet bug I have no idea...
Comment 5 Dave Jones 2006-07-25 23:06:11 EDT
Is there any BIOS update for this system by any chance ?
Comment 6 Dave Jones 2006-10-16 15:10:38 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 7 David Bowen 2006-10-16 17:46:09 EDT
Thank you for your patience so far, and this updated information.

I have taken the updated kernel using yum:

[root@somehost ~]# uname -a
Linux somehost 2.6.18-1.2200.fc5 #1 SMP Sat Oct 14 16:59:56 EDT 2006 x86_64
x86_64 x86_64 GNU/Linux

I can confirm that the machines boots fine and that the nvidia driver works too.

Unfortunately, when I enable Cool'n'Quiet I have problems with yum again. I'm
assuming yum is just an example of a program stressing the machine. The errors I
got were:

--> Running transaction check
Segmentation fault

and

--> Running transaction check
memory alloc (449356 bytes) returned NULL.

I also got this rather strange error which I won't try to interpret:

Reading repository metadata in from local files
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 97, in main
    result, resultmsgs = do()
  File "/usr/share/yum-cli/cli.py", line 481, in doCommands
    return self.updatePkgs()
  File "/usr/share/yum-cli/cli.py", line 961, in updatePkgs
    self.doUpdateSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 326, in
doUpdateSetup
    self.up.doUpdates()
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 248, in
doUpdates
    (new_e,new_v,new_r) = self.returnNewest(newpkgs[(n, a)])
KeyError: ('compat-gda-sqlite', 'x86_64')

With the old kernel and Cool'n'Quiet disabled I have been working the machine
without incident since June. Some of that time has been spent running yum and
other even more stressful tasks.

I found this entry in /var/log/messages:

yum[2717]: segfault at 0000000000000064 rip 00000037f39d270c rsp
00007fff7507d360 error 4

Here's my yum version info in case that is relevant:

[root@somehost ~]# yum --version
2.6.1

I'm sorry I haven't got round to looking into a BIOS upgrade so far.

Please let me know if there's some information you'd like me to capture or a
test you'd like me to run.

I know you are very busy, so please don't let this distract you from more
important tasks.
Comment 8 Dave Jones 2006-10-16 18:08:44 EDT
Have a look around for a BIOS update. It could be that the cool'n'quiet tables
contain bogus values.

This problem is repeatable without the vmware modules loaded right ?
Comment 9 David Bowen 2006-10-16 18:17:50 EDT
The motherboard / BIOS details are:

Phoenix - AwardBIOS v6.00PG, An Energy Star Ally
Copyright (C) 1984-2006, Phoenix Technologies, LTD

ASUS M2N-E ACPI BIOS Revision 0103

Main  Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+

<snip>

This information is presented during the boot process (the "powernow-k8" line is
indeed repeated as shown):

<snip>

powernow-k8: MP systems not supported by PSB BIOS structure
powernow-k8: MP systems not supported by PSB BIOS structure

<snip>

kernel direct mapping tables up to 1000000000 @ 8000-d000

I'm afraid I'm still not in a position to risk a BIOS update, but I will
continue to try to do so.

Since taking the kernel update the VMWare modules refuse to load. I need to
rebuild them to get them to load. The yum problem is occuring at this time even
without the VMWare modules loaded.
Comment 10 David Bowen 2006-10-16 19:07:58 EDT
About the BIOS update:

The ASUS website states that my CPU is supported by my BIOS. Sadly they don't
make this info directly hyper-linkable:

http://support.asus.com.tw/cpusupport/cpusupport.aspx

There is a newer BIOS, but it would appear they have chosen to make it
installable using a program called "WinFlash" that only runs under the Windows
operating system :

http://support.asus.com.tw/technicaldocuments/technicaldocuments.aspx?no=503&SLanguage=en-us

http://support.asus.com.tw/technicaldocuments/technicaldocuments_content.aspx?no=195&SLanguage=en-us

As I don't have access to a Windows licence I'm afraid I can't install this BIOS
update. That's an unfortunate consequence of me choosing the hardware I did and
the support offered by the vendor.

Comment 11 David Bowen 2006-10-16 19:12:14 EDT
Created attachment 138639 [details]
Output of lshw

I'm attaching more detail from lshw and cpuinfo just in case it helps.

# cat /proc/cpuinfo
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 75
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
stepping	: 2
cpu MHz 	: 2210.211
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id 	: 0
cpu cores	: 2
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm
3dnowext 3dnow pni cx16 lahf_lm cmp_legacy svm cr8_legacy
bogomips	: 4424.85
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment : 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc
Comment 12 Rob Andrews 2007-01-10 04:44:19 EST
Just on the off chance, I checked the ASUS download page for the M2N-E board,
and under the "BIOS" tab there is a DOS Award/Phoenix BIOS flashing tool. The
URL for this is:

  http://dlsvr03.asus.com/pub/ASUS/mb/flash/AWDFLASH118.zip

And the latest BIOS for the board is:

  http://dlsvr03.asus.com/pub/ASUS/mb/socketAM2/M2N-E/0602.zip

If you need a DOS boot disk to update the board, you can fetch one from
http://www.bootdisk.com/.
Comment 13 David Bowen 2008-03-15 22:22:03 EDT
I'm clearly not getting round to looking into this and there's no sign of that
changing any time soon. Please shelve this issue appropriately - I'm afraid I
can't see a suitable resolution.

Sorry.
Comment 14 Bug Zapper 2008-04-03 23:11:03 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 15 Bug Zapper 2008-05-06 12:03:32 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.