Bug 197159 - At exit, audio applications cause a kernel error, and subseqently can't start until reboot
At exit, audio applications cause a kernel error, and subseqently can't start...
Status: CLOSED DUPLICATE of bug 194597
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 18:14 EDT by Alan Coleman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 10:16:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Coleman 2006-06-28 18:14:08 EDT
Description of problem:

Since upgrading to the latest kernel, I have observed that my sound
applications, specifically rosegarden and ardour cause a kernel error when they
exit.

After this happens, I cannot start any of them until I reboot.  These apps are
from PlanetCCRMA, but I have only installed the apps themselves, not any of
PlanetCCRMA's other foo.

This stuff all worked two kernel updates ago (ie at 2.6.16-1.2122 it worked)

Version-Release number of selected component (if applicable):

Linux speedpenguin 2.6.17-1.2139_FC5 #1 Fri Jun 23 12:40:16 EDT 2006 i686 athlon
i386 GNU/Linux

How reproducible:

Install Rosegarden from PlanetCCRMA.  Start it.  Do something.  Quit.

You won't be able to start it again.

Here is the info the kernel dumped to the log file:

Jun 28 15:08:00 speedpenguin gconfd (acoleman-2572): Resolved address
"xml:readwrite:/home/acoleman/.gconf" to a writable configuration source at
position 1
Jun 28 15:08:00 speedpenguin gconfd (acoleman-2572): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
Jun 28 15:08:02 speedpenguin gconfd (acoleman-2572): Resolved address
"xml:readwrite:/home/acoleman/.gconf" to a writable configuration source at
position 0
Jun 28 15:10:02 speedpenguin kernel: List corruption. next->prev should be
de385c48, but was e91a1c68
Jun 28 15:10:02 speedpenguin kernel: ------------[ cut here ]------------
Jun 28 15:10:02 speedpenguin kernel: kernel BUG at include/linux/list.h:58!
Jun 28 15:10:02 speedpenguin kernel: invalid opcode: 0000 [#1]
Jun 28 15:10:02 speedpenguin kernel: last sysfs file: /block/hda/hda1/size
Jun 28 15:10:02 speedpenguin kernel: Modules linked in: snd_rtctimer
snd_seq_midi autofs4 sunrpc ip_conntrack_netbios_ns ipt_REJECT xt_state
ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables video button
battery ac ipv6 lp parport_pc parport usb_storage ehci_hcd ohci1394 ieee1394
uhci_hcd sg nvidia(U) floppy snd_emu10k1_synth snd_emux_synth snd_seq_virmidi
snd_seq_midi_emul snd_emu10k1 snd_rawmidi snd_ac97_codec snd_ac97_bus
snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_pcm_oss snd_mixer_oss
snd_pcm snd_seq_device snd_timer snd_page_alloc emu10k1_gp gameport via_rhine
snd_util_mem snd_hwdep snd i2c_viapro mii i2c_core soundcore dm_snapshot dm_zero
dm_mirror dm_mod raid1 ext3 jbd sata_via libata sd_mod scsi_mod
Jun 28 15:10:02 speedpenguin kernel: CPU:    0
Jun 28 15:10:02 speedpenguin kernel: EIP:    0060:[<f8976234>]    Tainted: P   
  VLI
Jun 28 15:10:02 speedpenguin kernel: EFLAGS: 00210086   (2.6.17-1.2139_FC5 #1) 
Jun 28 15:10:02 speedpenguin kernel: EIP is at
snd_seq_delete_all_ports+0x60/0x176 [snd_seq]
Jun 28 15:10:02 speedpenguin kernel: eax: 00000044   ebx: de3ce448   ecx:
c06bbfd0   edx: dd770550
Jun 28 15:10:02 speedpenguin kernel: esi: de385c48   edi: e91a1c68   ebp:
e91a1be0   esp: dd7edde0
Jun 28 15:10:02 speedpenguin kernel: ds: 007b   es: 007b   ss: 0068
Jun 28 15:10:02 speedpenguin kernel: Process rosegardenseque (pid: 2719,
threadinfo=dd7ed000 task=dd770550)
Jun 28 15:10:02 speedpenguin kernel: Stack: f8977432 de385c48 e91a1c68 e91a1c7c
e91a1c70 00200286 22222222 22222222 
Jun 28 15:10:02 speedpenguin kernel:        e91a1be0 f1f2006c f1f2006c df1eb780
f89711bc e91a1be0 f897126e 00000000 
Jun 28 15:10:02 speedpenguin kernel:        f1f201f4 00000008 e91a1be0 f89712bc
00000008 c045ce66 00000000 f184aef8 
Jun 28 15:10:02 speedpenguin kernel: Call Trace:
Jun 28 15:10:02 speedpenguin kernel:  <f89711bc> seq_free_client1+0x8/0x7e
[snd_seq]  <f897126e> seq_free_client+0x3c/0x78 [snd_seq]
Jun 28 15:10:02 speedpenguin kernel:  <f89712bc> snd_seq_release+0x12/0x31
[snd_seq]  <c045ce66> __fput+0xb2/0x158
Jun 28 15:10:02 speedpenguin kernel:  <c045a798> filp_close+0x52/0x59 
<c041d914> put_files_struct+0x63/0xa5
Jun 28 15:10:02 speedpenguin kernel:  <c041e9db> do_exit+0x1f8/0x768  <c042479b>
__dequeue_signal+0x149/0x154
Jun 28 15:10:02 speedpenguin kernel:  <c041efb8> sys_exit_group+0x0/0xd 
<c042609a> get_signal_to_deliver+0x3a8/0x3d0
Jun 28 15:10:02 speedpenguin kernel:  <c04023df> do_notify_resume+0x74/0x5f6 
<c045c74f> vfs_read+0x110/0x14e
Jun 28 15:10:02 speedpenguin kernel:  <c0402d42> work_notifysig+0x13/0x19 
Jun 28 15:10:02 speedpenguin kernel: Code: 00 00 74 6d 8b 9d 88 00 00 00 8b b5
8c 00 00 00 8b 43 04 39 f0 74 1c 89 74 24 04 89 44 24 08 c7 04 24 32 74 97 f8 e8
8f 67 aa c7 <0f> 0b 3a 00 1d 74 97 f8 8b 06 39 d8 74 1c 89 5c 24 04 89 44 24 
Jun 28 15:10:02 speedpenguin kernel: EIP: [<f8976234>]
snd_seq_delete_all_ports+0x60/0x176 [snd_seq] SS:ESP 0068:dd7edde0
Jun 28 15:10:02 speedpenguin kernel:  <3>BUG: sleeping function called from
invalid context at include/linux/rwsem.h:43
Jun 28 15:10:02 speedpenguin kernel: in_atomic():0, irqs_disabled():1
Jun 28 15:10:02 speedpenguin kernel:  <c0426d8d>
blocking_notifier_call_chain+0x18/0x49  <c041e7fc> do_exit+0x19/0x768
Jun 28 15:10:02 speedpenguin kernel:  <c05290e7> do_unblank_screen+0x2a/0x127 
<c04042c0> die+0x27b/0x2a0
Jun 28 15:10:02 speedpenguin kernel:  <c04048a5> do_invalid_op+0x0/0xab 
<c0404947> do_invalid_op+0xa2/0xab
Jun 28 15:10:02 speedpenguin kernel:  <f8976234>
snd_seq_delete_all_ports+0x60/0x176 [snd_seq]  <c04186cb> try_to_wake_up+0xe9/0xf3
Jun 28 15:10:02 speedpenguin kernel:  <c042f6aa>
debug_mutex_add_waiter+0x1c/0x2c  <c04037df> error_code+0x4f/0x54
Jun 28 15:10:02 speedpenguin kernel:  <f8976234>
snd_seq_delete_all_ports+0x60/0x176 [snd_seq]  <f89711bc>
seq_free_client1+0x8/0x7e [snd_seq]
Jun 28 15:10:02 speedpenguin kernel:  <f897126e> seq_free_client+0x3c/0x78
[snd_seq]  <f89712bc> snd_seq_release+0x12/0x31 [snd_seq]
Jun 28 15:10:02 speedpenguin kernel:  <c045ce66> __fput+0xb2/0x158  <c045a798>
filp_close+0x52/0x59
Jun 28 15:10:03 speedpenguin kernel:  <c041d914> put_files_struct+0x63/0xa5 
<c041e9db> do_exit+0x1f8/0x768
Jun 28 15:10:03 speedpenguin kernel:  <c042479b> __dequeue_signal+0x149/0x154 
<c041efb8> sys_exit_group+0x0/0xd
Comment 1 Alan Coleman 2006-06-28 18:15:59 EDT
Oh, just a couple more versions of things for completeness:

rosegarden4-1.2.3-1.rhfc5.ccrma
jack-audio-connection-kit-0.101.1-9.fc5
alsa-lib-1.0.11-4.rc2
Comment 2 Matthew Miller 2006-06-29 10:16:03 EDT

*** This bug has been marked as a duplicate of 194597 ***

Note You need to log in before you can comment on or make changes to this bug.