Bug 197164 - libss can't use readline due to unresolved symbols
libss can't use readline due to unresolved symbols
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 18:45 EDT by Nalin Dahyabhai
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: readline-5.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 12:24:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one possible way to "fix" it, also includes the change for bug #197160 (2.15 KB, patch)
2006-06-28 18:47 EDT, Nalin Dahyabhai
no flags Details | Diff

  None (edit)
Description Nalin Dahyabhai 2006-06-28 18:45:48 EDT
Description of problem:
When libss attempts to dlopen libreadline, it frequently fails because neither
the calling application nor libreadline is linked with either libtermcap or
libncurses, so the undefined symbols can't all be resolved.

Version-Release number of selected component (if applicable):
1.38-15

How reproducible:
Always

Steps to Reproduce:
1. Run 'debugfs'.
2. Type any invalid command.
3. Press the 'Up' key.
  
Actual results:
You see a control sequence

Expected results:
You see the invalid command you typed

Additional info:
This also affects various apps in the krb5 package, which also uses libss (see
bug #197044), but I figured it'd be simpler to fix it in the e2fsprogs package.
Comment 1 Nalin Dahyabhai 2006-06-28 18:47:37 EDT
Created attachment 131705 [details]
one possible way to "fix" it, also includes the change for bug #197160
Comment 2 Eric Sandeen 2007-09-19 12:12:40 EDT
Well, FWIW, the testcase works now :)

[root@newbox ~]# debugfs /dev/sda1
debugfs 1.40.2 (12-Jul-2007)
debugfs:  asdfasdf
debugfs: Unknown request "asdfasdf".  Type "?" for a request list.
<up key>
debugfs:  asdfasdf

looking into what changed.
Comment 3 Nalin Dahyabhai 2007-09-19 12:16:49 EDT
Looks like libreadline is linking directly with libtinfo now, apparently since
readline-5.2-3.  So we can probably close this.  Thanks!
Comment 4 Eric Sandeen 2007-09-19 12:24:29 EDT
Will do, thanks :)

Note You need to log in before you can comment on or make changes to this bug.