Bug 197207 - [zh_TW] In Anaconda GUI screens, the "( )" on the "Next" and other buttons, are cutting
[zh_TW] In Anaconda GUI screens, the "( )" on the "Next" and other buttons, a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: fonts-chinese (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
David Lawrence
: i18n
: 198343 (view as bug list)
Depends On:
Blocks: 205171
  Show dependency treegraph
 
Reported: 2006-06-29 04:55 EDT by Satyabrata Maitra
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: fonts-chinese-3.02-6.fc6, fonts-chinese-3.02-7.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 05:11:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot-Anaconda-1 (56.43 KB, image/png)
2006-06-29 04:55 EDT, Satyabrata Maitra
no flags Details
Screenshot-Anaconda-2 (20.11 KB, image/png)
2006-06-29 04:56 EDT, Satyabrata Maitra
no flags Details
Screenshot-Anaconda-3 (25.04 KB, image/png)
2006-06-29 05:04 EDT, Satyabrata Maitra
no flags Details
Screenshot-Anaconda-4 (28.55 KB, image/png)
2006-06-29 05:04 EDT, Satyabrata Maitra
no flags Details
Screenshot-Anaconda-5 (24.54 KB, image/png)
2006-06-29 05:05 EDT, Satyabrata Maitra
no flags Details
shot (7.69 KB, image/png)
2006-07-27 19:21 EDT, Behdad Esfahbod
no flags Details
patch of the ")" cutting (525 bytes, patch)
2006-08-18 05:02 EDT, Caius Chance
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 328374 None None None Never

  None (edit)
Description Satyabrata Maitra 2006-06-29 04:55:39 EDT
Description of problem:
In Anaconda GUI installation, in the buttons like "Next", "Back", "Release
Note", the Closing ")" is cutting from the middle. Please see the screenshot
attached.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.45-1.i386

How reproducible:
Always

Steps to Reproduce:
1. Start RHEL5-Alpha GUI installation
2. Select the Language korean (zh_TW)
3. Go through the installation with Next screens.
4. Observe the Buttons on each screen.
  
Actual results:
In the (B), (N), (R) and other buttons, closing ")" is cutting.

Expected results:
All opening "(" and closing ")" should appear and show fully without cutting.

Additional info:
Screenshots attached. Please see.
Comment 1 Satyabrata Maitra 2006-06-29 04:55:40 EDT
Created attachment 131724 [details]
Screenshot-Anaconda-1
Comment 2 Satyabrata Maitra 2006-06-29 04:56:54 EDT
Created attachment 131725 [details]
Screenshot-Anaconda-2
Comment 3 Satyabrata Maitra 2006-06-29 05:04:09 EDT
Created attachment 131726 [details]
Screenshot-Anaconda-3
Comment 4 Satyabrata Maitra 2006-06-29 05:04:46 EDT
Created attachment 131727 [details]
Screenshot-Anaconda-4
Comment 5 Satyabrata Maitra 2006-06-29 05:05:15 EDT
Created attachment 131728 [details]
Screenshot-Anaconda-5
Comment 6 Jeremy Katz 2006-06-29 11:15:39 EDT
Do you get this in gtk apps post-install?  I can't think of anything strange
we'd be doing that would cause this
Comment 7 Leon Ho 2006-07-11 21:50:31 EDT
Post-install has the same problem, moving this to pango.
Comment 8 Behdad Esfahbod 2006-07-11 22:44:59 EDT
What font is it?  I highly suspect bogus font metrics.
Comment 9 Leon Ho 2006-07-12 00:05:40 EDT
it is uming.ttf in fonts-chinese package. The glyphs used there is the embedded
bitmap set in the font.
Comment 10 Behdad Esfahbod 2006-07-27 19:09:34 EDT
*** Bug 198343 has been marked as a duplicate of this bug. ***
Comment 11 Behdad Esfahbod 2006-07-27 19:18:50 EDT
Ok, confirmed that this is a bug in the bitmap embedded in the font.  The bitmap
for ")" should be shifted one pixel to the left.

Try these and use xmag to inspect results:

   pango-view --font "AR PL ShanHeiSun Uni 11" --text "Next (N)"
(press 'b' to see the logical (red) and visual (green) borders)

   pango-view --font "AR PL ShanHeiSun Uni 11" --text "Next (N)" --margin 0
(observe the bug)

   pango-view --font "AR PL ShanHeiSun Uni 11" --text ")" --margin 0
   pango-view --font "AR PL ShanHeiSun Uni 11" --text "(" --margin 0
Comment 12 Behdad Esfahbod 2006-07-27 19:21:15 EDT
Created attachment 133207 [details]
shot

Screenshot of xmag showing enlarged output of the following commands:

   pango-view --font "AR PL ShanHeiSun Uni 11" --text ")" --margin 0
   pango-view --font "AR PL ShanHeiSun Uni 11" --text "(" --margin 0

See how ")" has two empty pixels on the left.
Comment 14 Caius Chance 2006-08-18 03:28:57 EDT
Using fontforge, it discovers the problem regarding the cutting:

1. Start fontforge and load /usr/share/fonts/chinese/TrueType/uming.ttf
2. Click on U+0029 i.e. ")"
3. On menu, select Element > Find Problems. then click OK
4. A window come up said "The paths that make up this glyph intersect one other

It might be not the problem of positioning geometry.
Comment 15 Caius Chance 2006-08-18 04:34:39 EDT
Bitmap glyph size 13 & 15 fixed in uming.ttf
Comment 16 Caius Chance 2006-08-18 05:02:30 EDT
Created attachment 134427 [details]
patch of the ")" cutting

glyph shows properly on runlevel 5

needs upstream confirmation
Comment 17 Caius Chance 2006-08-23 03:30:08 EDT
Modified on:

- RHEL-5 beta
- fc5
- devel

Built and waiting for QA's test.
Comment 18 Satyabrata Maitra 2006-08-31 07:04:57 EDT
The problem of cutting ")" in both zh_CN and zh_TW has still not fixed. 

Component Version Tested : anaconda-11.1.0.77-6 (RHEL5 Beta)
Comment 20 Satyabrata Maitra 2006-09-01 07:44:32 EDT
Hi Caius

Yesterday I tested it on RHEL5 beta. result given above.

Today I tested it on rawhide and this issue is fixed in Rawhide.

Component Version tested :

anaconda-11.1.0.88-1.

Still I would like to know the method to update fonts-chinese during or before
the Anaconda Installation. Because, Its confusing for me as anaconda comes
before the machine is ready to install or update anything. Thanks a lot!!

Satya
Comment 22 Caius Chance 2006-09-05 02:24:35 EDT
Please reconfirm if QC is on the built proposed package:

fonts-chinese-3.02-7.el5
Comment 23 Satyabrata Maitra 2006-09-05 05:11:58 EDT
Hi Caius

Thanks for your explinations!! I got it!! I downgraded the font-chinese cnd
observed the problem. Tested on rawhide. Its fixed now, I confirmed from
Lawrence also based on Brisbane that in EL 5 this has been fixed also. I think
he also tested it with the latest version in El5, to be sure once again. But it
is confirmed that this issue has been resolved now in El5. So I am closing this
bug for now. Please reopen it again if required in future!!

Component Version Tested :
fonts-chinese-3.02-6.fc6
fonts-chinese-3.02-7.el5

Note You need to log in before you can comment on or make changes to this bug.