Bug 19724 - man-pages are corrupted
man-pages are corrupted
Status: CLOSED CURRENTRELEASE
Product: Red Hat Powertools
Classification: Retired
Component: lapack (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-24 17:08 EDT by Michael Moellney
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 17:08:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Moellney 2000-10-24 17:08:34 EDT
Using man to read the man pages of package lapack-man-3.0-4-i386.rpm leads
to outputs like:

DGESV(l)                        )                        DGESV(l)

NAME
       DGESV  -  compute  the solution to a real system of linear
       equations  E * X = B,

SYNOPSIS
       TINE DGESV( N, NRHS, A, LDA, IPIV, B, LDB, INFO ) FO )

           R       INFO, LDA, LDB, N, NRHS NRHS

           R       IPIV( * )  * )

           PRECISION A( LDA, * ), B( LDB, * )  * )


having a wrong formatted SYNOPSIS'.
Some leading information seems to be cut off. INTEGER -> R ... and so on..

Please fix this, thanks, Michel
Comment 1 Trond Eivind Glomsrxd 2000-10-25 12:34:56 EDT
I can't reproduce this in Red Hat Linux 7.


Does the man page source look OK? (just zcat through a pipe to less)
Comment 2 Michael Moellney 2000-10-26 05:10:46 EDT
a)

Using "zcat /usr/man/manl/dgesv.l.gz | less" delivers:

.TH DGESV l "30 November 1999" "LAPACK version 3.0" ")"
.SH NAME
DGESV - compute the solution to a real system of linear equations ^@ E * X = B,
.SH SYNOPSIS
.TP 12
TINE DGESV(
N, NRHS, A, LDA, IPIV, B, LDB, INFO ) ^@FO )
.TP 12
.ti +4
R
INFO, LDA, LDB, N, NRHS ^@NRHS
.TP 12
.ti +4
R
IPIV( * ) ^@ * )
.TP 12
.ti +4
PRECISION A( LDA, * ), B( LDB, * ) ^@ * )
.SH PURPOSE
DGESV computes the solution to a real system of linear equations
   A * X = B,
where A is an N-by-N matrix and X and B are N-by-NRHS matrices.


so the part after .SH SYNOPSIS looks disturbed...

rpm -qf /bin/zcat
gzip-1.2.4a-2

b)
Using lapack-man-3.0-8 of RH 7.0 Powertools has rightly formatted man pages, but
the  man path is /usr/share/man that is not in the default man path of RH 6.2
Comment 3 Trond Eivind Glomsrxd 2000-10-26 12:19:13 EDT
OK, so the man page source look bad in 6.2. "rpm -V lapack-man" and "rpm -K
your.i386.rpm" seem OK?

Anyway, a solution is to use the new RPM, and add /usr/share/man to
/etc/man.config

Note You need to log in before you can comment on or make changes to this bug.