Bug 197256 - massive SELinux denial spewage
Summary: massive SELinux denial spewage
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: oddjob   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 197182
TreeView+ depends on / blocked
 
Reported: 2006-06-29 18:06 UTC by Nalin Dahyabhai
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 20:12:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nalin Dahyabhai 2006-06-29 18:06:52 UTC
Running oddjobd 0.26 on Raw Hide currently causes massive numbers of SELinux
policy denials to be logged.  The D-BUS maintainer tells me that it's because
oddjobd subscribes to all messages using dbus_bus_add_match(""), though it has
no need to do so as unicast messages are always routed properly, and this is
what's triggering the denials.

I need to double-check that removing this call doesn't break anything on FE3/4/5
(which contain older versions of D-BUS which may or may not have required this
to be done) before making this fix for the upstream release.

Comment 1 Nalin Dahyabhai 2006-07-20 20:12:58 UTC
Fixed in oddjob 0.27.  There are no ill effects from removing the above
add_match call, at least as far back as D-BUS 0.22.  The oddjob 0.27 release
also fixes a compilation failure against D-Bus 0.90.


Note You need to log in before you can comment on or make changes to this bug.