Bug 19729 - 2.2.16-22's adm9240.o won't make (Makefile typo)
2.2.16-22's adm9240.o won't make (Makefile typo)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-24 18:14 EDT by Luno
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 23:14:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luno 2000-10-24 18:14:25 EDT
Here's the diff, from the released 2.2.16-22 kernel sources...

--- drivers/sensors/Makefile~	Tue Aug 22 14:24:01 2000
+++ drivers/sensors/Makefile	Tue Oct 24 14:49:35 2000
@@ -33,10 +33,10 @@
   endif
 endif
 
-ifeq ($(CONFIG_SENSORS_ADM9024),y)
+ifeq ($(CONFIG_SENSORS_ADM9240),y)
   L_OBJS += adm9240.o
 else
-  ifeq ($(CONFIG_SENSORS_ADM9024),m)
+  ifeq ($(CONFIG_SENSORS_ADM9240),m)
     M_OBJS += adm9240.o
   endif
 endif
Comment 1 Luno 2000-10-29 20:29:38 EST
Also note that due to this (pardon the afterthought), the module isn't included
in the standard distro's collection in /lib/modules/2.2.16-22/whatever.

Note that after this change, using the stock kernel config (non-enterprise,
non-smp), make_modules DID make the module, so I can only assume that you had
intended for it to be included.

- luno AT luno.org



Note You need to log in before you can comment on or make changes to this bug.