Bug 19732 - svgalib package is broken in 7.0
svgalib package is broken in 7.0
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: svgalib (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
:
: 19733 19869 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-24 21:43 EDT by Stan Bubrouski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-26 09:10:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stan Bubrouski 2000-10-24 21:43:31 EDT
Due to misconfigured compilation options the sgvalib package that comes
with 7.0 seems to be broken when compiling apps with svgalib support.  The
result of  the problem is that linking
of programs with -lvga included cause ld to exit complaining
/usr/lib/libvga.so.1 contains undefined references to __global_sti
__global_cli.

I noticed this trying to compile a couple things so I tried uninstalling
the svgalib and svgalib-devel packages and tried rebuilding from the source
RPM.  Building subsequently failed because ld was unable to find -lvga when
linking some stuff.  This tells me that if I had an older version of
svgalib installed it would use that to link the utils that come with
svgalib and could break a new install svgalib.  My assumption is that when
the svgalib packages that come with Red Hat 7.0 were built on a system
containing an older install of svgalib and this caused the package breakage
I am experiencing.  After applying the following patch I was able to
rebuild svgalib packages, install them, and the linking problem went away.

--- svgalib-1.4.1/utils/Makefile.stan   Tue Oct 24 20:55:46 2000
+++ svgalib-1.4.1/utils/Makefile        Tue Oct 24 20:59:54 2000
@@ -16,6 +16,9 @@
 CFLAGS = $(WARN) $(OPTIMIZE) -I../include
 #Use the next one for the Alpha/AXP if you need it
 #LDFLAGS = -L../staticlib 
+
+#This seems to be needed for linking when svgalib package is not already
installed.
+LDFLAGS = -L../sharedlib
 LIBS = -lvga -lm
 
 #----------------------------------------------------------------------
Comment 1 Ngo Than 2000-10-26 09:10:37 EDT
*** Bug 19733 has been marked as a duplicate of this bug. ***
Comment 2 Ngo Than 2000-10-26 10:05:05 EDT
It's fixed in svgalib-1.4.1-12.
Comment 3 Ngo Than 2000-10-30 04:20:37 EST
*** Bug 19869 has been marked as a duplicate of this bug. ***
Comment 4 Need Real Name 2000-10-30 05:00:48 EST
The updated svgalib-1.4.1-12 seems not to have reached rawhide.redhat.com.
As of 30-10-2000, only svgalib-1.4.1-11 can be reached there.
Comment 5 Stan Bubrouski 2000-11-06 01:50:17 EST
Was fixed in an errata no in rawhide.  This should be changed to Resolution:
ERRATA as it is accurate whereas RAWHIDE is not.  The URL Of the updated
packages for 7.0 English is:

ftp://updates.redhat.com/powertools/7.0/i386/svgalib-1.4.1-12.i386.rpm
ftp://updates.redhat.com/powertools/7.0/i386/svgalib-devel-1.4.1-12.i386.rpm
ftp://updates.redhat.com/powertools/7.0/SRPMS/svgalib-1.4.1-12.src.rpm

-Stan Bubrouski

Note You need to log in before you can comment on or make changes to this bug.