Bug 19733 - svgalib package is broken in 7.0
svgalib package is broken in 7.0
Status: CLOSED DUPLICATE of bug 19732
Product: Red Hat Linux
Classification: Retired
Component: svgalib (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Depends On:
  Show dependency treegraph
Reported: 2000-10-24 21:43 EDT by Stan Bubrouski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-24 21:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stan Bubrouski 2000-10-24 21:43:44 EDT
Due to misconfigured compilation options the sgvalib package that comes
with 7.0 seems to be broken when compiling apps with svgalib support.  The
result of  the problem is that linking
of programs with -lvga included cause ld to exit complaining
/usr/lib/libvga.so.1 contains undefined references to __global_sti

I noticed this trying to compile a couple things so I tried uninstalling
the svgalib and svgalib-devel packages and tried rebuilding from the source
RPM.  Building subsequently failed because ld was unable to find -lvga when
linking some stuff.  This tells me that if I had an older version of
svgalib installed it would use that to link the utils that come with
svgalib and could break a new install svgalib.  My assumption is that when
the svgalib packages that come with Red Hat 7.0 were built on a system
containing an older install of svgalib and this caused the package breakage
I am experiencing.  After applying the following patch I was able to
rebuild svgalib packages, install them, and the linking problem went away.

--- svgalib-1.4.1/utils/Makefile.stan   Tue Oct 24 20:55:46 2000
+++ svgalib-1.4.1/utils/Makefile        Tue Oct 24 20:59:54 2000
@@ -16,6 +16,9 @@
 CFLAGS = $(WARN) $(OPTIMIZE) -I../include
 #Use the next one for the Alpha/AXP if you need it
 #LDFLAGS = -L../staticlib 
+#This seems to be needed for linking when svgalib package is not already
+LDFLAGS = -L../sharedlib
 LIBS = -lvga -lm

-Stan Bubrouski
Comment 1 Ngo Than 2000-10-26 09:10:40 EDT

*** This bug has been marked as a duplicate of 19732 ***

Note You need to log in before you can comment on or make changes to this bug.