Bug 197342 - mail-notification opens configuration dialog on every login
mail-notification opens configuration dialog on every login
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 08:26 EDT by Joachim Selke
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 11:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Selke 2006-06-30 08:26:22 EDT
Description of problem:
On my system mail-notification is started on every GNOME login because of
/usr/share/gnome/autostart/fedora-mail-notification.desktop. If there are no
mailboxes configured for use with mail-notification then the configuration
dialog of mail-notification pops up on login.

At the moment I do not want to use mail-notification (but some others users want
so the package cannot be removed) so this dialog is quite annoying. Is there a
simple way to disable it? The dialog seems not to give this opportunity.


Version-Release number of selected component (if applicable):
3.0-1.fc5
Comment 1 Thorsten Leemhuis 2006-07-02 05:56:53 EDT
(In reply to comment #0)
> At the moment I do not want to use mail-notification (but some others users want
> so the package cannot be removed) so this dialog is quite annoying. Is there a
> simple way to disable it? The dialog seems not to give this opportunity.

No idea -- I need to look into this, but that might take a while because I'm on
vacation and quite busy with other stuff. Sorry.
Comment 2 Joachim Selke 2006-07-02 06:24:54 EDT
I think a good fix for this bug would be to remove the file
/usr/share/gnome/autostart/fedora-mail-notification.desktop from the
mail-notification package. Then users who want to use mail-notification can
launch mail-notification from the "System -> Preferences -> More Preferences"
menu, configure it, and use the "Save current setup" mechanism of their desktop
environment to get it started automatically on every login.

What do you think about this idea?
Comment 3 Thorsten Leemhuis 2006-07-02 06:31:22 EDT
(In reply to comment #2)
> I think a good fix for this bug would be to remove the file
> /usr/share/gnome/autostart/fedora-mail-notification.desktop from the
> mail-notification package. Then users who want to use mail-notification can
> launch mail-notification from the "System -> Preferences -> More Preferences"
> menu, configure it, and use the "Save current setup" mechanism of their desktop
> environment to get it started automatically on every login.
> 
> What do you think about this idea?

If you tested it and it works -- mostly okay. But upstream puts the file into a
autostart folder on purpose (I put it in a slightly different dir that more
proper for modern systems). The question is: why? There is probably a reason and
this probably should be fixed or discussed with the author of mail-notification. 
Comment 4 Joachim Selke 2006-07-02 07:21:10 EDT
(In reply to comment #3)
> If you tested it and it works -- mostly okay.

I tested it, and it works perfectly.

The NEWS file in the source package of mail-notification says:

--
The "Start Mail Notification on GNOME login" option no longer worked with GNOME
>= 2.14 and has been removed: a .desktop file is now installed in the xdg      
           autostart directory instead.
--

So it seems there was an option "Start Mail Notification on GNOME login" in the
configuration dialog that made trouble in recent versions of GNOME. The
workaround by creating the autostart file mentioned there is overkill in my
opinion -- at least for FC5. There it is possible to automatically start
mail-notification the way I described in comment #2.
Comment 5 Thorsten Leemhuis 2006-08-07 11:52:44 EDT
I talked with the author of mail-notification. He doesn't want to change the
current behaviour afaics.

I agree that the things you suggest in #2 should work in general, but they make
finding and using mail-notification much harder.

I came to the conclusion that they make it to hard and that I don't want to
differ to much from upstream. I therefor won't change the behaviour and will
close this as WONTFIX. Feel free to make noise on the mailinglists if you think
that I'm an idiot.

The proper solution would be to show the initial config dialog only once per
user and or add a checkbox "don't show configure dialog again". I'm probably
willing to apply a patch in the fedora package that implements one of those
behaviours if someone comes up with one.
Comment 6 Joachim Selke 2006-08-10 03:32:29 EDT
(In reply to comment #5)
> I agree that the things you suggest in #2 should work in general, but they
> make finding and using mail-notification much harder.

This argument applies to nearly any other application that is not started on
login. So why not start every application on login? I still think its bad
behavior if some user-related application is started automatically without user
intervention; it is even worse if this startup cannot be disabled.

> I came to the conclusion that they make it to hard and that I don't want to
> differ to much from upstream. I therefor won't change the behaviour and will
> close this as WONTFIX. Feel free to make noise on the mailinglists if you
> think that I'm an idiot.

The only difference from upstream then would be not to include
/usr/share/gnome/autostart/fedora-mail-notification.desktop. That's far from
being critical.

Maybe I am an idiot, I don't know. I will ask the people on the devel-list for
their opinion on this "bug".

> The proper solution would be to show the initial config dialog only once per
> user and or add a checkbox "don't show configure dialog again".

But then still any user who does not want to use mail-notification is irritated
by the config dialog. I can't think of any other Fedora application that raises
a config dialog on login by default.
Comment 7 Thorsten Leemhuis 2006-08-10 03:46:51 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > I agree that the things you suggest in #2 should work in general, but they
> > make finding and using mail-notification much harder.
> 
> This argument applies to nearly any other application that is not started on
> login. So why not start every application on login? I still think its bad
> behavior if some user-related application is started automatically without user
> intervention; it is even worse if this startup cannot be disabled.

I tend to agree. But please tell upstream, because that's the proper place where
it IMHO should be fixed. I tried, but failed. Maybe it helps when more people
poke upstream ;-)
 
> > I came to the conclusion that they make it to hard and that I don't want to
> > differ to much from upstream. I therefor won't change the behaviour and will
> > close this as WONTFIX. Feel free to make noise on the mailinglists if you
> > think that I'm an idiot.
> 
> The only difference from upstream then would be not to include
> /usr/share/gnome/autostart/fedora-mail-notification.desktop. That's far from
> being critical.

It's not the technical difference, it's the usage that differs from the docs and
howtos on the net.

> Maybe I am an idiot, I don't know. I will ask the people on the devel-list for
> their opinion on this "bug".

Feel free.

Note You need to log in before you can comment on or make changes to this bug.