Bug 197378 - sound works for 'root' only
sound works for 'root' only
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 13:55 EDT by George Arseneault
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 09:18:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from "ls -l /dev/snd/" (637 bytes, text/plain)
2006-07-10 12:21 EDT, George Arseneault
no flags Details

  None (edit)
Description George Arseneault 2006-06-30 13:55:36 EDT
Description of problem:
added alsa compatible soundcard, and had it up and running. 
now, every time I log in as anything other than root, I get:
  error while initializing sound driver:
  device: default can't be opened for playback (permission denied)
  The sound server will continue, using the null output device

when I use administration-soundcard detection, I get sound. But, it won't work 
outside that app. unless I login as root

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: The only thing I did prior to the sound failure was, to login 
as root in an attempt to mount my main hard drive. (Windows fat32, I have a 
dual boot setup) By the way, I also get "permission denied" every time I 
attempt this, even as root.

I cannot find any config settings for either of these permissions. please 
advise.
Comment 1 Martin Stransky 2006-07-01 16:14:24 EDT
Please log-in as a common user and attach output of "ls -l /dev/snd/"
Comment 2 George Arseneault 2006-07-10 12:21:33 EDT
Created attachment 132185 [details]
output from "ls -l /dev/snd/"

I found a fix in the question & answers of the aRts Handbook, but I'd still
appreciate any other advice you can give me.  Thanks.

BTW do you know anything about the "permission denied" when I try to mount the
windows drive? Could it be because I enabled SELinux when I installed it?
Comment 3 Martin Stransky 2006-12-14 09:18:09 EST
All files here (/dev/snd/) look fine...

Note You need to log in before you can comment on or make changes to this bug.