Bug 19740 - kde start menu: redhat entries
kde start menu: redhat entries
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-25 04:05 EDT by Gerald Teschl
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-02 08:57:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2000-10-25 04:05:49 EDT
This applies to version 2.0-1.

The redhat entries (/etc/X11/applnk/) appear twice in the kde start menu.
They are listed under the item RedHat and merged into the main tree.
Turning the option
"Merge different menu locations" off has no effect.

Please remove them from the main tree!
Comment 1 Bernhard Rosenkraenzer 2000-10-25 05:45:00 EDT
No. They belong to the main tree because the typical user doesn't care whether he's launching a KDE application or a different application, and having to look under a Red Hat submenu to find an application is counter-intuitive.

We'll remove the Red Hat submenu in the next tree
Comment 2 Gerald Teschl 2000-10-25 13:16:33 EDT
Talkning about "intuive" you should probably clean up /etc/X11/applnk and fix
the icon
size problem (the firewall-config icon looks particularly great at 42x42) before
you merge
the trees:

Why is emacs under Applications and not Editors?
Why is xfig under Applications and not under Graphics?
Why is acroread under Graphics and xpdf under Applications?
How many KDE users do you think want to start xxgdb from the KDE menue? Same
applies
to all other terminal applications elm/mutt/.....
Remove stale desktop files which don't correspond to applications
(nmapfe.desktop,...)
And so on and so on....

So if you want to make it more user friendly, please take these points into
account.

Comment 3 ryan v... 2000-10-25 14:04:12 EDT
personally, I prefer to have the RedHat-specific stuff seperated out. I really
don't like (or use) many of the apps that appear under the RedHat menus (xfig,
etc)... and don't really want them in my main kde menus. Lastly, if you're going
to put them both places, allow me to remove them from one place and keep them in
the other. Currently, I went in and removed many of the items that are rather
unimportant to me from the main kde menues... imagine my shock to discover they
were gone from the RedHat menus as well!  (while on the subject, how the hell do
you get them back?)
Comment 4 Bernhard Rosenkraenzer 2000-11-02 08:57:45 EST
Mst of us prefer having the stuff merged, so that's the way we're going. If you don't like it, change it:
- Remove the dir_apps line from /etc/kderc
- Add a symlink: ln -s /etc/X11/applnk /usr/share/applnk/Red\ Hat

Since both are generated from the same directory, there's no way to keep them truly separate (so you could keep stuff in one place and remove it in the other).

Note You need to log in before you can comment on or make changes to this bug.