Bug 197403 - DHCP net install fails (HTTP)
DHCP net install fails (HTTP)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 18:03 EDT by John Reiser
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 13:54:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen photograph of VT1 showing traceback (94.94 KB, image/jpeg)
2006-08-03 14:52 EDT, John Reiser
no flags Details
screen photograph of VT3 showing log (168.70 KB, image/jpeg)
2006-08-03 14:53 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2006-06-30 18:03:50 EDT
Description of problem:
Attempt to install via HTTP fails, after booting from Rescue CD on PowerPC (32-bit).

Version-Release number of selected component (if applicable):
anaconda-11.1.0.50-1

How reproducible:
always

Steps to Reproduce:
1. using Rescue CD: "boot: linux askmethod" HTTP DHCP
2. specify a mirror and directory
3.
  
Actual results:
"install terminated abnormally" immediatly after specifying mirror and directory.

Expected results:
successful install

Additional info:
See the screen photograph
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=131808
Apparently resolver configuration (DNS) failed.

This present bug was filed to separate the issue from bug 196749.
Hardware is builtin ethernet on Apple Macintosh PowerPC Power Mac G4 model M8570
"silver drive doors" circa 2003.
Comment 1 John Reiser 2006-06-30 18:07:48 EDT
The present bug was filed to separate the issue from
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=195749
[sorry for typo in initial entry.]
Comment 2 Jeremy Katz 2006-07-03 23:46:00 EDT
Can you try from a newer tree with anaconda-11.0.1.51?
Comment 3 John Reiser 2006-07-04 13:38:28 EDT
FC-development-ppc-rescuecd.iso	2006-Jul-03 01:33:09	23.9M
gets past the problem.  It downloaded stage2.img, switched to graphical mode,
and  proceeded.  Apparently it is using anaconda-11.1.0.51-1.src.rpm 2006-Jun-30
13:40:47; the last announcement about anaconda was from "rawhide report:
20060630 changes" and listed version 11.1.0.50-1, which fails.   SHA1SUM of the
July 3 .iso is 7c4c40eaccc0ae9e341343b66f04de23fb3141a5.

I wonder whether the .iso is the rescue cd, because a rescue is generally about
99MB.  This one is only 23.9MB, which is more like a boot cd.  "boot: linux
rescue" soon gets a dialog "Rescue Method" which asks where the rescue files
are: Local CDROM, nfs, FTP, HTTP, etc.
Comment 4 Jeremy Katz 2006-07-05 11:45:41 EDT
The move of stage2.img broke rescue CD generation, I fixed that up.  But good
that HTTP is working now... on to new breakage! :)
Comment 5 John Reiser 2006-07-08 10:18:23 EDT
Still fails DHCP ("install exited abnormally [1/1]") using
FC-development-ppc-rescuecd.iso	2006-Jul-08 01:36:35	99.4M
sha1sum=08734f6ecdd3913503a2e3dc2a39950e358db4ae

After "boot: linux askmethod", language, keyboard, HTTP, DHCP+IPv4, server and
path, then VT3 shows lines for: DHCP obtained lease, option subnet-mask, option
subnet-mask [another], option routers: [empty].  Then:
ERROR: nic_configure: failed to configure resolver
INFO: reesult of pumpSetupInterface is DHCP configuration failed - 1 Operation
not permitted
WARNING: reverse name lookup failed

Retrying with DHCP+IPv4+IPv6 also failed (after IPv6 timeout, because there is
no IPv6 on this network).

Retrying also fails using explicit configuration (IPv4 only, no DHCP, no IPv6)
of IP address, subnet mask, gateway.
Comment 6 John Reiser 2006-07-08 10:21:52 EDT
Supposedly today's rescue CD has anaconda-11.1.0.54-1.  During manual
configuration, I also supplied a correct IPv4 for name server, but the install
still exited abnormally.
Comment 7 Jeremy Katz 2006-07-10 20:22:55 EDT
Does it work if you don't have to retry?
Comment 8 John Reiser 2006-07-10 22:25:29 EDT
Still fails.  I gave the correct parameters (IP4, netmask, gateway, nameserver)
manually the first time to the network configuration dialog, but the install
still gave "install exited abnormally [1/1]".  Full sequence: "boot: linux
askmethod", language, keyboard; no DHCP, IPv4, no IPv6; network parameters [OK].
 VT3 showed only INFO lines (no ERROR), and the only one that looked network
related was "eth0 is not a wireless adapater".

FC-development-ppc-rescuecd.iso	2006-Jul-10 01:25:35	99.5M
sha1sum=eb4b67b82c76a5f829a60aecdf4322b92f225d6a

Comment 9 John Reiser 2006-07-10 23:29:28 EDT
Also still fails (in same way as Comment #8) on i386:
FC-development-i386-rescuecd.iso	2006-Jul-10 01:19:31	79.0M
sha1sum=e3fba9a3220a24595bfe7079d9a6eae4f94440d6
Comment 10 John Reiser 2006-07-12 17:51:35 EDT
Still no joy with anaconda-11.1.0.56-1  FC-development-ppc-rescuecd.iso
2006-Jul-12 05:24:21	99.1M sha1sum=f9cb2a602003f12c4553e0c3cba1d88eab024269;
linux askmethod, language, keyboard, HTTP.

First try with DHCP and IPv4 only (no IPv6): install exited abnormally [1/1]. 
VT3  shows DHCPDISCOVER, DHCPOFFER, DHCPREQUEST, DHCPACK, bound to 192.168.0.2,
DHCPv4 eth0 - obtained lease 192.168.0.2, DHCPv4 eth0 - option subnet-mask:
255.255.255.0, DHCPv4 eth0 - option subnet-mask - prefix_len:24 broadcast:
192.168.0.255, DHCPv4 eth0 - option routers:, ERROR : nic_configure: failed to
configure resolver, INFO : result of pumpSetupInterface is DHCP configuration
failed- 1 Operation not permitted.

Retry also failed with same messages, except an additional line Error : add:
failed - 17: Netlink Error (errno= File exists); which appeared before the
nic_configure line.

Rebooting and trying manual configuration first (no DHCP, IPv4 only, no IPv6),
using 192.168.0.2/255.255.255.0 [why not use the word "netmask"?], gateway
192.168.0.1, broadcast 192.168.0.255, nameserver xxx.yyy.zzz.www [obfuscated,
but good]; proceeded to HTTP configure, but "fedora.cat.pdx.edu" was not a valid
hostname. Neither was "http://fedora.cat.pdx.edu", nor "mirrors.kernel.org", nor
"http://mirrors.kernel.org".  However, these are valid hostnames.

Comment 11 John Reiser 2006-07-14 13:41:25 EDT
Today anaconda-11.1.0.57-1 "install exited abnormally [1/1]" immediately after
HTTP setup dialog.  FC-development-ppc-rescuecd.iso	2006-Jul-14 04:37:01	109.9M
 sha1sum=730e7fec81d7027e2c3362519c04ef9932d6e1d2

I specified "fedora.cat.pdx.edu" in the Website field, and
"linux/core/development/ppc/os" in the Directory field.  I got the abnormal exit
message for both DHCP configure, and for manual configure [after reboot; retry
was not allowed.]  For both DHCP and manual, then VT3 showed "INFO : starting to
STEP_URL".  For DHCP, preceding lines had DHCPDISCOVER, DHCPOFFER, DHCPREQUEST,
DHCPACK, bound to, obtained lease, option subnet-mask, prefix_len:24, option
routers:<empty>, and WARNING: reverse name lookup failed.

So there is no warning about nameserver itself, but also there is no concrete
indication of successful nameserver.  The explanation for the "install exited
abnormally" seems to be missing from both VT1 and VT3.
Comment 12 Joseph Sacco 2006-07-17 09:57:45 EDT
The problem persists as of 16-july-06.

-Joseph
Comment 13 John Reiser 2006-07-18 11:35:47 EDT
Still fails using FC-development-ppc-rescuecd.iso	2006-Jul-18 05:27:30	110.2M
sha1sum=f6f18940bed9982071541ff51bbe14c24b5ab7c8.

I tried both DHCP+IPv4 (no IPv6) and manual configuration.  "install exited
abnormally [1/1]" on VT1.  On VT3 there were the same lines as Comment #11 above.
Comment 14 John Reiser 2006-07-19 08:19:03 EDT
Still failes using anaconda-11.1.0.60-1  FC-development-ppc-rescuecd.iso
2006-Jul-19 01:40:17	110.3M sha1sum=e48946180c19233bfbc43278148becb1b2e9982c.
Comment 15 John Reiser 2006-07-21 10:53:50 EDT
Still fails under anaconda-11.1.0.62-1  FC-development-ppc-rescuecd.iso
2006-Jul-21 01:27:42	111.1M  sha1sum=7a2fa58e058e79c38d2a4f138b01c7ee94000da1. 
"boot: linux askmethod", language, keyboard, HTTP; DHCP, IPv4, no IPv6; [DHCP
succeeds]; network site, directory; "install exited abnormally [1/1]".  It also
fails in the same way if I configure IPv4 manually (without DHCP).

If I "boot: linux rescue" using the same CD, and try to start the network
interfaces, then I don't get a chance to un-enable IPv6 (like I now do with the
'askmethod' boot), and it hangs trying to start eth0.  I gave up after three
minutes.
Comment 16 John Reiser 2006-07-25 10:50:11 EDT
Still fails under anaconda-11.1.0.64-1  FC-development-ppc-rescuecd.iso
2006-Jul-25 01:29:41	112.4M  sha1sum=2af08a18c6c33dc080b427939c8a46b20413672c.
But, progress: loader received SIGSEGV!  Backtrace:
[0x1000037c]
[0x100374]
[0x10177f9c]
[0x1001d9c8]
[0x10017498]
[0x10002c24]
[0x10141450]
[0x10141600]
install exited abnormally [1/1]

Also, booting "linux resuce" and asking to start the network interfaces, still
gets no response after several minutes.  VT1 shows "Starting Interface" with
"Attempting to start eth0".  There are no unusual messages on VT3.  Running 'ps'
under the shell on VT2 shows that python ananconda is looping (cpu time goes up
at nearly 100%.)
Comment 17 David Cantrell 2006-07-25 11:04:20 EDT
Well that's something to go on.  Looking in to getting a reproducer locally. 
I'll post with updates.
Comment 18 John Reiser 2006-07-26 09:21:56 EDT
Today's anaconda-11.1.0.65-1 using FC-development-ppc-rescuecd.iso	2006-Jul-26
01:37:36	112.4M sha1sum=000f8e40e8a02d392ce2e53489df092c0717531f gives the same
traceback as Comment #16.
Comment 19 John Reiser 2006-07-28 09:36:01 EDT
Today's traceback is
1000037c
100374
1016e42c
1001d698
10017660
10002bf8
10137cb0
10137e60

anaconda-11.1.0.72-1  FC-development-ppc-rescuecd.iso	2006-Jul-28 01:37:28
112.4M  sha1sum=ea9553b43c46081f2e57e33feeba3f67b80f911c.
Comment 20 John Reiser 2006-07-29 10:52:07 EDT
Today's traceback is
1000037c
100374
1017821c
1001d6c8
10017690
10002ad0
101416d0
10141880

anaconda-11.1.0.73-1  FC-development-ppc-rescuecd.iso	2006-Jul-29 01:31:26
112.4M  sha1sum=e6aa236fcc1747e83fec787a56c1457d109a5f94.
Comment 21 John Reiser 2006-08-01 09:45:46 EDT
Today's traceback is
1000037c
100374
101775bc
1001d688
10002ad0
101413d4
10141570

anaconda-11.1.0.74-1  FC-development-ppc-rescuecd.iso	2006-Aug-01 01:39:15
112.5M  sha1sum=8349862e5386598c0653c06ba8fd317e63b2924b.
Comment 22 David Cantrell 2006-08-03 13:22:13 EDT
I have tried this today with boot.iso and the rescuecd image on both ppc and
i386.  I boot using 'linux askmethod'.  I select my interface and DHCP
configuration.  I ask for the HTTP installation method.

Both systems complete stage1 and proceed to stage2 without any problems.  Using
boot.iso, the stage2 image is downloaded from the HTTP site.  Using the rescuecd
method, the stage2 image is mounted from the rescue CD.

This was all done with today's rawhide tree (20060803).
Comment 23 John Reiser 2006-08-03 14:50:59 EDT
Please re-open.  It still fails for me, on two different Apple Macintosh PowerPC
machines.  Both the rescuecd and the boot.iso fail with the same traceback on
both systems (4 identical failures and tracebacks.)  anaconda-11.1.0.77-1
FC-development-ppc-rescuecd.iso	2006-Aug-03 01:44:13	113.3M
sha1sum=cc936387edbf93dc53b6dd007ed90fb0cd5af439 (both downloaded file and
physical CD-ROM after burning)
boot.iso	2006-Aug-03 01:38:31	39.7M 
sha1sum=ba5cb26ee49f276a9d497b1f40cf82b9d1001f82 (both downloaded file and
physical CD-ROM after burning)

boot: linux askmethod; English; us; HTTP; {Use DHCP, Enable IPv4, no Enable
IPv6}; {fedora.cat.pdx.edu, linux/core/development/ppc/os}; loader received
SIGSGEV! traceback:
0x1000037c
0x100374
0x101772dc
0x1001d6e8
0x100176c0
0x10002aa0
0x101410f4
0x10141290

The machines are Apple Macintosh PowerMac G4 tower, Model M8570 "silver drive
doors" circa 2002-2003, and Apple Macintosh Mini (PowerPC) circa 2005.

I will attach screen photographs of VT1 and VT3 at the time of the crash.

Both machines have FC5 installed, so please ask for other info if needed.

VT2 does not yet have a shell, so I cannot use gdb, etc.
Comment 24 John Reiser 2006-08-03 14:52:32 EDT
Created attachment 133575 [details]
screen photograph of VT1 showing traceback
Comment 25 John Reiser 2006-08-03 14:53:42 EDT
Created attachment 133576 [details]
screen photograph of VT3 showing log
Comment 26 David Cantrell 2006-08-03 16:02:26 EDT
Put the leading slash on the HTTP path name. Instead of
linux/core/development/ppc/os, put /linux/core/development/ppc/os
Comment 27 John Reiser 2006-08-03 16:52:42 EDT
Hurrah!  Using /linux/core/development/ppc/os with the leading slash works!  I
get at least as far as the graphical partitioning screen after choosing Create
custom layout (where I stopped to relay the good news in this Comment.)

[Such expensive consequences for a syntax error.]
Comment 28 Chris Lumens 2006-08-08 15:56:01 EDT
*** Bug 196334 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.