Bug 19741 - ip-up.local not executed
Summary: ip-up.local not executed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-25 08:59 UTC by Tomasz Kepczynski
Modified: 2014-03-17 02:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-26 11:58:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomasz Kepczynski 2000-10-25 08:59:30 UTC
The following line is executed in ip-up before ip-up.local is called:
/etc/sysconfig/network-scripts/ifup-post ifcfg-${LOGDEVICE}
The problem is that ifcfg-ppp0 (or whatever) is not used in kppp and
doesn't exist. Therefore ifup-post exits with nonzero exit code and ip-up
script is aborted. The following may fix that problem:

[ -f /etc/sysconfig/network-scripts/ifcfg-${LOGDEVICE} ] && \
  /etc/sysconfig/network-scripts/ifup-post ifcfg-${LOGDEVICE}

Comment 1 Bill Nottingham 2000-12-26 05:51:13 UTC
Will be fixed in initscripts-5.54-1 - thanks.


Note You need to log in before you can comment on or make changes to this bug.