Bug 197425 - iptab fails to print IP address table
iptab fails to print IP address table
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Net-IP (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-01 04:15 EDT by Kazuyuki Maejima
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.25-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 13:02:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazuyuki Maejima 2006-07-01 04:15:50 EDT
Description of problem:
It prints error message instead of its IP address table.

Version-Release number of selected component (if applicable):
1.25-1.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Run iptab.
$ iptab
  
Actual results:
+----------------------------------------------+
| addrs   bits   pref   class  mask            |
+----------------------------------------------+
Can't call method "is_zero" on an undefined value at
/usr/lib/perl5/5.8.8/Math/BigInt.pm line 1148.

Expected results:
+----------------------------------------------+
| addrs   bits   pref   class  mask            |
+----------------------------------------------+
|            0    /32          255.255.255.255 |
|     2      1    /31          255.255.255.254 |
|     4      2    /30          255.255.255.252 |
|     8      3    /29          255.255.255.248 |
|    16      4    /28          255.255.255.240 |
|    32      5    /27          255.255.255.224 |
|    64      6    /26          255.255.255.192 |
|   128      7    /25          255.255.255.128 |
|   256      8    /24      1C  255.255.255.0   |
|   512      9    /23      2C  255.255.254.0   |
|    1K     10    /22      4C  255.255.252.0   |
|    2K     11    /21      8C  255.255.248.0   |
|    4K     12    /20     16C  255.255.240.0   |
|    8K     13    /19     32C  255.255.224.0   |
|   16K     14    /18     64C  255.255.192.0   |
|   32K     15    /17    128C  255.255.128.0   |
|   64K     16    /16      1B  255.255.0.0     |
|  128K     17    /15      2B  255.254.0.0     |
|  256K     18    /14      4B  255.252.0.0     |
|  512K     19    /13      8B  255.248.0.0     |
|    1M     20    /12     16B  255.240.0.0     |
|    2M     21    /11     32B  255.224.0.0     |
|    4M     22    /10     64B  255.192.0.0     |
|    8M     23     /9    128B  255.128.0.0     |
|   16M     24     /8      1A  255.0.0.0       |
|   32M     25     /7      2A  254.0.0.0       |
|   64M     26     /6      4A  252.0.0.0       |
|  128M     27     /5      8A  248.0.0.0       |
|  256M     28     /4     16A  240.0.0.0       |
|  512M     29     /3     32A  224.0.0.0       |
| 1024M     30     /2     64A  192.0.0.0       |
| 2048M     31     /1    128A  128.0.0.0       |
| 4096M     32     /0    256A  0.0.0.0         |
+----------------------------------------------+

Additional info:
iptab of perl-Net-IP-1.24-2.2 in FC5 works ok.
Comment 1 Kazuyuki Maejima 2006-07-03 21:59:26 EDT
I've found the cause of the problem.
http://rt.cpan.org/Public/Bug/Display.html?id=20265
Comment 2 Jason Vas Dias 2006-07-05 15:52:06 EDT
Now fixed with perl-Net-IP-1.25-2.fc6 - suggested patch at 
 http://rt.cpan.org/Public/Bug/Display.html?id=20265
applied.
Comment 3 Robin Norwood 2006-11-22 13:02:40 EST
Seems to be fixed in fc6.

Note You need to log in before you can comment on or make changes to this bug.