Bug 197437 - netatalk conflicts with the latest libgssapi
netatalk conflicts with the latest libgssapi
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: netatalk (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Maros Barabas
:
Depends On:
Blocks: 197421
  Show dependency treegraph
 
Reported: 2006-07-01 09:45 EDT by Bruno Wolff III
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: netatalk-2.0.3-5.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-14 10:24:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2006-07-01 09:45:42 EDT
Description of problem:
netatalk needs libgssapi.so.1 which is not provided by 
libgssapi-0.9-1.FC5.i386.rpm.

Version-Release number of selected component (if applicable):
2.0.3-4.2.1

How reproducible:
100%

Steps to Reproduce:
1. rpm -Uvh netatalk-2.0.3-4.2.1.i386.rpm
2.
3.
  
Actual results:
[root@bruno RPMS]# rpm -Uvh netatalk-2.0.3-4.2.1.i386.rpm
error: Failed dependencies:
        libgssapi.so.1 is needed by netatalk-2.0.3-4.2.1.i386


Expected results:
Clean install

Additional info:
If netatalk is installed first and you try to update libgssapi-0.7-2.1.i386.rpm
to libgssapi-0.9-1.FC5.i386.rpm the same conflict will be reported.
Comment 1 josip 2006-07-01 09:56:09 EDT
Same problem:
yum install netatalk
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core                                                                 [1/4]
updates                                                              [2/4]
base                                                                 [3/4]
extras                                                               [4/4]
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for netatalk to pack into transaction set.
netatalk-2.0.3-4.2.1.x86_ 100% |=========================|  39 kB    00:04
---> Package netatalk.x86_64 4:2.0.3-4.2.1 set to be updated
--> Running transaction check
--> Processing Dependency: libgssapi.so.1()(64bit) for package: netatalk
--> Finished Dependency Resolution
Error: Missing Dependency: libgssapi.so.1()(64bit) is needed by package netatalk

# rpm -q libgssapi
libgssapi-0.9-1.FC5
Comment 2 Jason Vas Dias 2006-07-05 15:43:57 EDT
Now fixed with netatalk-2.0.3-5.fc5, now being release to FC-5 Updates -
only a rebuild against latest libgssapi rpm was required.
Comment 3 Fedora Update System 2006-07-06 23:43:39 EDT
netatalk-2.0.3-5.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Bruno Wolff III 2006-07-08 00:43:12 EDT
It now works for me.
Comment 5 Bruno Wolff III 2007-04-14 10:24:14 EDT
I think it is safe to close this one now.

Note You need to log in before you can comment on or make changes to this bug.