Bug 197457 - pirut unable to import modules - missing requires cairo>x
pirut unable to import modules - missing requires cairo>x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pycairo (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-01 22:57 EDT by David Timms
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-03 23:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec patch to require cairo greater or equal to 1.1.10-1 (584 bytes, patch)
2006-07-01 22:57 EDT, David Timms
no flags Details | Diff

  None (edit)
Description David Timms 2006-07-01 22:57:35 EDT
Description of problem:
pirut is installed but neither pirut nor pup will start.

Version-Release number of selected component (if applicable):
pirut-1.1.2-1.noarch.rpm

How reproducible:
Possibly only during an upgrade to FC6t1 on a disk space limited machine.

Steps to Reproduce:
1. yum upgrade pirut
2.a. pirut
  b. pup

Actual results:
a. Unable to import modules. Maybe you're not running under X?
b. Traceback (most r c last):
File "/usr/sbin/pup", line 29, in ?
  import gtk
File "/usr/lib/pyhton2.4/site-packages/gtk-2.0/gtk/__init__.py", line 45, in ?
  import _gtk import *
File "/usr/lib/pyhton2.4/site-packages/cairo/__init__.py", line 1, in ?
  import _cairo import *
ImportError: /usr/lib/pyhton2.4/site-packages/cairo/_cairo.su: undefined symbol:
cairo_ps_surface_create

Expected results:
pup or pirut runs.

Additional info:
Machine had FC5 on it, doing small size at a time upgrade to fc6t1.
cairo.i386                               1.0.4-1                installed
Available Packages
cairo.i386                               1.1.10-1   
Updating cairo to fc6t1 solved the problem.
--requires for cairo is in a roundabout way.
[root@hpomnibook ~]# rpm -q --requires pirut
/bin/sh
/bin/sh
/usr/bin/python
comps-extras
desktop-file-utils >= 0.8
desktop-file-utils >= 0.8
gnome-python2-gconf
gnome-python2-libegg
pygtk2
pygtk2-libglade
python(abi) = 2.4
rhpl
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
yum >= 2.9.0-4
[root@hpomnibook ~]# rpm -q --requires pygtk2|grep cairo
libcairo.so.2
libpangocairo-1.0.so.0
pycairo
[root@hpomnibook ~]# rpm -q --requires pycairo|grep cairo
cairo
libcairo.so.2
Comment 1 David Timms 2006-07-01 22:57:35 EDT
Created attachment 131844 [details]
spec patch to require cairo greater or equal to 1.1.10-1
Comment 2 Jeremy Katz 2006-07-03 23:25:31 EDT
Nothing in pirut itself explicitly requires this -- it's pycairo that needs to
have better deps.  I've went ahead and fixed it up, though
Comment 3 David Timms 2006-07-04 09:15:30 EDT
Comment on attachment 131844 [details]
spec patch to require cairo greater or equal to 1.1.10-1

Thanks, wrong solution in proposed patch.

Note You need to log in before you can comment on or make changes to this bug.