Bug 197472 - anaconda breaks kadischi and livecd
anaconda breaks kadischi and livecd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-02 13:22 EDT by Chitlesh GOORAH
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-03 23:48:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2006-07-02 13:22:12 EDT
Description of problem:
While building livecds with kadischi and Jeremy's livecd, anaconda crashes.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.50-1
busybox-anaconda-1.1.3-2

How reproducible:
everytime

Steps to Reproduce:
1. ./livecd.py http://mirrors.kernel.org/fedora/core/development/i386/os/
/tmp/lo.iso
  
Actual results:
['/usr/sbin/anaconda', '--rootpath=cd:/tmp/kadischi.0TkT0O/system',
'--method=http://mirrors.kernel.org/fedora/core/development/i386/os/']
Traceback (most recent call last):
 File "/usr/sbin/anaconda", line 604, in ?
   import dispatch
 File "/usr/lib/anaconda/dispatch.py", line 19, in ?
   from packages import writeXConfiguration
 File "/usr/lib/anaconda/packages.py", line 27, in ?
   import fsset
 File "/usr/lib/anaconda/fsset.py", line 575, in ?
   fileSystemTypeRegister(gfsFileSystem())
 File "/usr/lib/anaconda/fsset.py", line 552, in __init__
   self.partedFileSystemType = parted.file_system_type_get("gfs")
parted.error: unknown file system type
anaconda failed.  Exiting

Steps to Reproduce:
actual kadischi cvs version.
1. kadischi http://mirrors.kernel.org/fedora/core/development/i386/os/ /tmp/lo.iso
  
Actual results:
Starting kadischi...
Parsing command line arguments
Checking UID
Using buildstamp file /etc/kadischi/buildstamp.
Product path set to Fedora.
Now we are going to try to validate your repository (for now, only
http, ftp and local repositories can be checked)
URL http://mirrors.kernel.org/fedora/core/development/i386/os contacted. OK
URL http://mirrors.kernel.org/fedora/core/development/i386/os/Fedora
contacted. OK
URL http://mirrors.kernel.org/fedora/core/development/i386/os/Fedora/base
contacted. OK
URL http://mirrors.kernel.org/fedora/core/development/i386/os/Fedora/RPMS
contacted. OK
Repository seems to be OK.
Checking required packages
Looking for config file
Loading config file options

 ***  running anaconda  ***

Traceback (most recent call last):
 File "/usr/sbin/anaconda", line 604, in ?
   import dispatch
 File "/usr/lib/anaconda/dispatch.py", line 19, in ?
   from packages import writeXConfiguration
 File "/usr/lib/anaconda/packages.py", line 27, in ?
   import fsset
 File "/usr/lib/anaconda/fsset.py", line 575, in ?
   fileSystemTypeRegister(gfsFileSystem())
 File "/usr/lib/anaconda/fsset.py", line 552, in __init__
   self.partedFileSystemType = parted.file_system_type_get("gfs")
parted.error: unknown file system type

 ***  Fatal error: /usr/sbin/anaconda returned non zero (256) exit
code. Aborting execution.

Cleaning up temporary files...
Done.



Expected results:
Build a livecd without, anaconda crashing everytime.

Additional info:
Comment 1 Jeremy Katz 2006-07-03 23:48:14 EDT
This is fixed in 11.1.0.51

Note You need to log in before you can comment on or make changes to this bug.