Bug 197474 - List corruption in ALSA sequencer API, kernel hangs/crashes
List corruption in ALSA sequencer API, kernel hangs/crashes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-02 14:41 EDT by Callum Lerwick
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 23:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A stack trace (4.06 KB, text/plain)
2006-07-02 14:41 EDT, Callum Lerwick
no flags Details

  None (edit)
Description Callum Lerwick 2006-07-02 14:41:04 EDT
Description of problem:

Any application using the ALSA sequencer API will cause the kernel to crash when
it terminates. With kernel 2.6.16-1.2133_FC5, the system will completely lock
up. With kernel 2.6.17-1.2139_FC5, it will dump a stack trace and recover,
however the ALSA sequencer driver will be locked up. Anything trying to use it
will hang when trying to open() /dev/snd/seq.

Kernel 2.6.16-1.2122_FC5 and earlier work fine.

Version-Release number of selected component (if applicable):
2.6.16-1.2133_FC5
2.6.17-1.2139_FC5

How reproducible:
Always.

Steps to Reproduce:
1. Start an application that uses the ALSA sequencer API. (qjackctl, hydrogen...)
2. Quit the application.
3. Check your syslog / Watch your system lock up
  
Actual results:
Kernel crashes/hangs.

Expected results:
No crash/hang.

Additional info:
I posted a thread to fedora-music-list following my attempts to track this down:

https://www.redhat.com/archives/fedora-music-list/2006-July/msg00000.html

I ran into a problem with apps segfaulting when the jack period size is too
small, I believe this to be an unrelated bug that just happens to trigger THIS
bug as well due the app terminating.

I have attached a log. A few more are available in that thread.
Comment 1 Callum Lerwick 2006-07-02 14:41:04 EDT
Created attachment 131856 [details]
A stack trace
Comment 2 Callum Lerwick 2006-07-02 15:00:52 EDT
Okay, I've tried this on PPC. On my iMac, on both 2.6.16-1.2133_FC5 and
2.6.17-1.2139_FC5 I get a total system lockup. No stack trace.

I have not yet run 2.6.16-1.2122_FC5 on it.
Comment 3 Dave Jones 2006-07-25 23:04:27 EDT
This should be fixed in the latest update.
Comment 4 Callum Lerwick 2006-07-29 22:06:41 EDT
Yup, seems to work now!

Note You need to log in before you can comment on or make changes to this bug.