Bug 197478 - default storage directory inaccessable (/builddir/.cpanplus)
default storage directory inaccessable (/builddir/.cpanplus)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-CPANPLUS (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-02 16:15 EDT by Chris Weyl
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-19 12:52:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2006-07-02 16:15:11 EDT
Description of problem:
CPANPLUS has a default directory of '/buildroot/.cpanplus', which causes Bad
Things to happen when apps try to use CPANPLUS without expliticly overriding. 
(e.g. scandeps.pl from perl-Module-ScanDeps)

Would it be possible to tweak Config.pm to alter the default behavior to, say,
$ENV{HOME}/.cpanplus, to make it more in line with the way perl(CPAN) does it? 

File: /usr/lib/perl5/vendor_perl/5.8.8/CPANPLUS/Config.pm
Line: 74
Comment 1 Steven Pritchard 2006-07-03 18:39:09 EDT
Does changing the line

 'base' => '/builddir/.cpanplus',

to

 'base' => "$ENV{HOME}/.cpanplus",

seem to work properly?
Comment 2 Chris Weyl 2006-07-03 20:18:56 EDT
Yes.
Comment 3 Chris Weyl 2007-02-19 12:52:00 EST
Long since fixed, so closing to get it off my frontpage :)

Note You need to log in before you can comment on or make changes to this bug.