Bug 197481 - kernel 2.6.17-1.2139_FC5 + xorg-x11-server-Xorg-1.0.1-9.fc5.5 freezes Dell Latitude D810
kernel 2.6.17-1.2139_FC5 + xorg-x11-server-Xorg-1.0.1-9.fc5.5 freezes Dell La...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-02 16:47 EDT by Alan Crosswell
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.17-1.2157_FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 10:13:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of pre-update rpms from /var/log/rpmpkgs (32.29 KB, text/plain)
2006-07-02 16:47 EDT, Alan Crosswell
no flags Details
list of post-update rpms from 'rpm -qa' (23.11 KB, text/plain)
2006-07-02 16:49 EDT, Alan Crosswell
no flags Details
/etc/X11/xorg.conf (3.31 KB, text/plain)
2006-07-02 16:50 EDT, Alan Crosswell
no flags Details
successful Xorg.0.log w/2.6.16 kernel (136.57 KB, text/plain)
2006-07-02 16:51 EDT, Alan Crosswell
no flags Details

  None (edit)
Description Alan Crosswell 2006-07-02 16:47:50 EDT
Description of problem:

I just did a yum update.  Rebooted.  When the Xorg server starts, the system
freezes (not even reachable over the net, so I assume it's a panic although
there's nothing to see on the laptop display as it had just blanked for the Xorg
server startup).

Version-Release number of selected component (if applicable):

kernel-2.6.17.1-2139_FC5

How reproducible:

Do a yum -y update (today:-).  Old and new rpmpkgs lists will be attached.

Steps to Reproduce:
1. install kernel-2.6.17 RPM and reboot
2. startx
  
Actual results:

Screen blanks.  Systems freezes.  Not reachable on the network.

Expected results:

Uhh, a login screen:-)

Additional info:

I at first suspected the updated Xorg RPMs but it turns out the difference is
the 2.6.17 kernel.  Reboot with kernel-2.6.16-1.2133_FC5 and Xorg starts up just
fine.

I googled 2.6.17 and there's some chatter between Linus and others about "X
being broken again" caused by changes to DRM in 2.6.17.
Comment 1 Alan Crosswell 2006-07-02 16:47:50 EDT
Created attachment 131860 [details]
list of pre-update rpms from /var/log/rpmpkgs
Comment 2 Alan Crosswell 2006-07-02 16:49:14 EDT
Created attachment 131861 [details]
list of post-update rpms from 'rpm -qa'
Comment 3 Alan Crosswell 2006-07-02 16:50:35 EDT
Created attachment 131862 [details]
/etc/X11/xorg.conf
Comment 4 Alan Crosswell 2006-07-02 16:51:56 EDT
Created attachment 131863 [details]
successful Xorg.0.log w/2.6.16 kernel
Comment 5 Davide Rossetti 2006-07-03 11:18:45 EDT
same here. on my Toshiba M40 with ATI M300.
I see lots of ACPI errors in dmesg if I boot at runlevel 3. going to level5 or
doing startx freezes the PC.
Comment 6 Alan Crosswell 2006-08-03 10:13:49 EDT
Appears to be working now when updating to kernel-2.6.17-1.2157_FC5
and xorg-x11-drv-ati-6.5.8.0-1 (not sure if it was the new kernel or new ati
drivers or both, but they both showed up with the most recent yum upgrade).

Note You need to log in before you can comment on or make changes to this bug.