Bug 197495 - The source rpm does not build.
The source rpm does not build.
Status: CLOSED NOTABUG
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
:
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
 
Reported: 2006-07-03 04:21 EDT by John Summerfield
Modified: 2007-05-16 09:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 22:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Summerfield 2006-07-03 04:21:55 EDT
Description of problem:

The source rpm does not build.

Version-Release number of selected component (if applicable):


How reproducible:

Infallibly.

Steps to Reproduce:
1.rpmbuild -ba /home/summer/redhat/SPECS/fedora-ds.spec
2.
3.
  
Actual results:
[summer@Wagtail ~]$ rpmbuild -ba /home/summer/redhat/SPECS/fedora-ds.spec
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.5133
+ umask 022
+ cd /home/summer/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ echo yes
+ echo yes
+ ./setup -b /home/summer/redhat/BUILD//opt/fedora-ds
/var/tmp/rpm-tmp.5133: line 30: ./setup: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.5133 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.5133 (%install)
[summer@Wagtail ~]$ sec bugz
bash: sec: command not found
[summer@Wagtail ~]$ grep  bugz .secrets
bugzilla ximian summer@summer.ami.com.au ycphhrlh
bugzilla.redhat.com debian@herakles.homelinux.org Password: 7K6UqF#S
kde bugzilla summer@computerdatasafe.com.au bert
https://bugzilla.ubuntu.com dingo@coco2.arach.net.au/ bert
[summer@Wagtail ~]$ 
ls -dl /home/summer/redhat/SOURCES/fedora-ds-1.0.tar.gz /home/summer/redhat/SPECS/fedora-ds.spec
-rw-rw-r-- 1 4511067 Nov 30  
2005 /home/summer/redhat/SOURCES/fedora-ds-1.0.tar.gz


Expected results:


Additional info:
Comment 1 Rich Megginson 2006-07-03 08:37:05 EDT
We expect to have a real, buildable RPM in the next major release.

Please see the http://directory.fedora.redhat.com/wiki/Building page and
especially the http://directory.fedora.redhat.com/wiki/Building#One-Step_Build
one step build instructions.  I don't think it will work directly on Debian
because of some implicit package or path dependencies, but if you do any work on
this, we would appreciate it if you could let us know what you find.  There is
also this:
http://directory.fedora.redhat.com/wiki/Howto:DebianUbuntu
Comment 2 John Summerfield 2006-07-27 09:05:27 EDT
I'm not interested in building it for Debian; I created the address when 
taroon was a beta:-)

It seems to me that fixing the rpm is going to take much the same amount of 
work whether it's done now or later, and that the sooner it's done the more 
people it's likely to help in being fixed.

Is there any chance you could bring this task forward?
Comment 3 Rich Megginson 2006-07-27 09:35:06 EDT
Yes.  It's pretty much all we're doing right now - rpm packaging improvements,
autotool-ization, and FHS.  If you want the blow-by-blow details, you can join
fedora-directory-devel -
http://www.redhat.com/mailman/listinfo/fedora-directory-devel
Comment 4 Rich Megginson 2007-03-15 22:51:25 EDT
The fedora-ds-base package is now in Fedora Extras and is available for FC5,
FC6, and FC7.  This package uses autotools for building and has a regular srpm.
 See
http://download.fedora.redhat.com/pub/fedora/linux/extras/5/SRPMS/fedora-ds-base-1.1.0-0.1.20070223.fc5.src.rpm

We're working on separate RPMS for console and admin server also.

Note You need to log in before you can comment on or make changes to this bug.