Bug 197503 - [zh_CN] Gedit inputing fullstop (" 。") only in two keyboard layouts, showing en_US type (".") in other layouts.
[zh_CN] Gedit inputing fullstop (" 。") only in two keyboard layouts, showin...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: scim-tables (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-03 08:06 EDT by Satyabrata Maitra
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 22:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2006-07-03 08:06:31 EDT
Description of problem:
In zh_CN locale, gedit is showing fullstop (after switch on SCIM) as circle ("
。")) in only Wubi and another keyboard layouts. For others, it is inputing as
en_US locale fullstop.

Version-Release number of selected component (if applicable):
gedit-2.15.3-1

How reproducible:
Always

Steps to Reproduce:

1. Start gedit with zh_CN locale.
2. Switch on SCIM with pressing CTRL+SPACE.
3. select any layouts (except Wubi and the last one) in zh_CN  (Chinese Simplified) 
     locale.
4. Press fullstop (".")from the keyboard.
5. Observe the result.
  
Actual results:
Fullstop in zh_CN is showing like en_US fullstop type (".").

Expected results:
It should be looking like circle (" 。").

Additional info:
Only in "Wubi" and the last one  layout is showing properly the fullstop.
Comment 1 Jens Petersen 2006-07-03 20:39:53 EDT
I think this is notabug.  Full-width punctation can be toggled
in for scim toolbar for scim-pinyin and scim-tables.

With scim-1.4.4-21 and later only Wubi and Smart Pinyin appear by default
in the scim submenu for Simplified Chinese and I can enter wide punctuation
fine with both of them.  Your report is related to the other scim-tables-chinese
tables?  Please the input methods explicitly.
Comment 2 Satyabrata Maitra 2006-07-27 11:20:35 EDT
Hi Jens

I tested it with latest rpms available in rawhide. The problem remains same and
still existing. Actually in this case what you will do, thats upto you as I do
not know much about chinese inputs and charecter's behaviors. If you think it is
enough to implement it only in 2 layouts its ok for me.

Another thing is that in your previous comment would you like to tell that I
should file a bug against scim-tables-chinese? or what. I did not understand.
Please explain a bit. Did not understand your last sentence also - "Please the
input methods explicitly.". What did you mean to say? please explain.

In the versions tested :

scim-qtimm-0.9.4-5
scim-pinyin-0.5.91-11.3.fc6
scim-bridge-gtkimm-0.2.6-1.fc6
scim-fcitx-3.1.1-5.fc6
scim-chinese-standard-0.0.2-3.fc6
scim-bridge-0.2.6-1.fc6
scim-input-pad-0.1.1-4.fc6
scim-libs-1.4.4-25.fc6
scim-devel-1.4.4-25.fc6
scim-fcitx-tools-3.1.1-5.fc6
scim-m17n-0.2.0-5.fc6
scim-doc-1.4.4-25.fc6
scim-tables-0.5.6-7
scim-tables-chinese-0.5.6-7
scim-chewing-0.3.1-2.1
scim-skk-0.5.2-7.fc6
scim-tomoe-0.2.0-4.fc6
scim-tables-additional-0.5.6-7

Comment 3 Jens Petersen 2006-07-27 22:12:11 EDT
This works for me for all Simplified Chinese tables.
This all use wide punctuation by default AFAICT (as does scim-pinyin
as you already noted).

Note You need to log in before you can comment on or make changes to this bug.