This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 197573 - Regression with lattest dmraid/device-mapper - SiI RAID1 ATA-RAID
Regression with lattest dmraid/device-mapper - SiI RAID1 ATA-RAID
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Heinz Mauelshagen
:
Depends On:
Blocks: 197980
  Show dependency treegraph
 
Reported: 2006-07-04 05:36 EDT by matti aarnio
Modified: 2008-03-12 02:08 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0.0.rc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 02:08:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
two JBODs + one pair of RAID1 on SiI 3114 (872 bytes, application/octet-stream)
2006-07-04 10:46 EDT, matti aarnio
no flags Details
SIL RAID1 disk partition table sector (512 bytes, application/octet-stream)
2006-07-04 12:54 EDT, matti aarnio
no flags Details
"fdisk -lu" output (sans stderr) in the system (2.95 KB, application/octet-stream)
2006-07-04 12:55 EDT, matti aarnio
no flags Details

  None (edit)
Description matti aarnio 2006-07-04 05:36:07 EDT
Description of problem:
  After updating system to FC5, my SiI (Silicon Image) ATA-RAID (RAID1)
  disk didn't find partitions and open them.

  Suspecting at first the kernel, hopped around with versions all the way
  to FC4 initial release x86-64 kernel.  Still nothing.

  Then begun to backdate  dmraid  utility, and finally FC4's version was
  able to access my disk with up to and including lattest Fedora development
  kernel.

Version-Release number of selected component (if applicable):
  failure: dmraid-1.0.0.rc11-FC6.x86_64.rpm
  failure: device-mapper-1.02.07-1.0.x86_64.rpm

  success: dmraid-1.0.0.rc8-FC4_5.x86_64.rpm
  success: device-mapper-1.01.02-1.0.x86_64.rpm

How reproducible:
  Extremely.  All you need is 

Steps to Reproduce:
1. Have: RAID bus controller: Silicon Image, Inc. SiI 3114 [SATALink/SATARaid]
Serial ATA Controller (rev 02)
2. Configure a pair of disks to be RAID1 (mirror)
3. Format them with FC4
4. Move them to FC5 machine (or upgrade to FC5)
  
Actual results:
  /dev/mapper/ directory does not show partition devices:
  crw------- 1 root root  10, 63 Jul  3 22:34 control
  brw-rw---- 1 root disk 253,  0 Jul  3 22:39 sil_afbidgcaafaj

  (this is synthetic result, but matches real case.)

Expected results:
  crw------- 1 root root  10, 63 Jul  3 22:34 control
  brw-rw---- 1 root disk 253,  0 Jul  3 22:39 sil_afbidgcaafaj
  brw-rw---- 1 root disk 253,  1 Jul  3 22:39 sil_afbidgcaafaj1
  brw-rw---- 1 root disk 253,  2 Jul  3 22:39 sil_afbidgcaafaj2
  brw-rw---- 1 root disk 253,  3 Jul  3 22:39 sil_afbidgcaafaj3


Additional info:

Successfull sofware:
# dmraid -f sil -ay -vvvv
WARN: locking /var/lock/dmraid/.lock
NOTICE: skipping removable device /dev/sdg
NOTICE: skipping removable device /dev/sdf
NOTICE: skipping removable device /dev/sde
NOTICE: /dev/sda: sil    discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
ERROR: sil: zero sectors on /dev/sda
ERROR: sil: setting up RAID device /dev/sda
NOTICE: /dev/sdb: sil    discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
ERROR: sil: zero sectors on /dev/sdb
ERROR: sil: setting up RAID device /dev/sdb
NOTICE: /dev/sdc: sil    discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdc: sil metadata discovered
NOTICE: /dev/sdd: sil    discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdd: sil metadata discovered
NOTICE: added /dev/sdc to RAID set "sil_afbidgcaafaj"
NOTICE: added /dev/sdd to RAID set "sil_afbidgcaafaj"
INFO: Activating mirror RAID set "sil_afbidgcaafaj"
NOTICE: discovering partitions on "sil_afbidgcaafaj"
NOTICE: /dev/mapper/sil_afbidgcaafaj: dos    discovering
NOTICE: /dev/mapper/sil_afbidgcaafaj: dos metadata discovered
NOTICE: created partitioned RAID set(s) for /dev/mapper/sil_afbidgcaafaj
INFO: Activating partition RAID set "sil_afbidgcaafaj1"
INFO: Activating partition RAID set "sil_afbidgcaafaj2"
INFO: Activating partition RAID set "sil_afbidgcaafaj3"
WARN: unlocking /var/lock/dmraid/.lock


Failing software:   (with some additional debug printouts)
./dmraid -f sil -ay -vvvv
NOTICE: checking format identifier sil
WARN: locking /var/lock/dmraid/.lock
NOTICE: skipping removable device /dev/sdg
NOTICE: skipping removable device /dev/sdf
NOTICE: skipping removable device /dev/sde
NOTICE: /dev/sda: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sda: sil metadata discovered
NOTICE: /dev/sdb: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdb: sil metadata discovered
NOTICE: /dev/sdc: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdc: sil metadata discovered
NOTICE: /dev/sdd: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdd: sil metadata discovered
NOTICE: sil.c::group_rd()
ERROR: sil: RAID type 255 not supported
ERROR: adding /dev/sda to RAID set "sil_afbgdjdeddbb"
ERROR: sil: RAID type 255 not supported
ERROR: adding /dev/sdb to RAID set "sil_afbgdjdecfbd"
NOTICE: added /dev/sdc to RAID set "sil_afbidgcaafaj"
NOTICE: added /dev/sdd to RAID set "sil_afbidgcaafaj"
INFO: Activating mirror RAID set "sil_afbidgcaafaj"
NOTICE: discovering partitions on "sil_afbidgcaafaj"
NOTICE: /dev/mapper/sil_afbidgcaafaj: dos     discovering
NOTICE: dos->magic = aa55   DOS_MAGIC = aa55
NOTICE: /dev/mapper/sil_afbidgcaafaj: dos metadata discovered
NOTICE: created partitioned RAID set(s) for /dev/mapper/sil_afbidgcaafaj
WARN: unlocking /var/lock/dmraid/.lock


  Note: The type "255" is "JBOD".
Comment 1 Heinz Mauelshagen 2006-07-04 07:53:57 EDT
That's irritating, because JBOD was never directly supported by the Silicon
Image metadata format handler.

Just to be sure: which dmraid version succeded to activate it ?

Please attach the output files created with that version and command 'dmraid
-rD' tar'ed/bzip2*ed in sil-matti_arrnio-jbod.tar.bz2 to this bugzilla.
Comment 2 matti aarnio 2006-07-04 10:21:43 EDT
I do wonder if "dmraid -rD" really is the interesting thing..
it is so small output that packing them into a file makes no sense.


# dmraid -V
dmraid version:         1.0.0.rc8 (2005.05.19) debug 
dmraid library version: 1.0.0.rc8 (2005.05.19)
device-mapper version:  4.7.0

# dmraid -rD
ERROR: sil: zero sectors on /dev/sda
ERROR: sil: setting up RAID device /dev/sda
ERROR: sil: zero sectors on /dev/sdb
ERROR: sil: setting up RAID device /dev/sdb
/dev/sdc: sil, "sil_afbidgcaafaj", mirror, ok, 490232704 sectors, data@ 0
/dev/sdd: sil, "sil_afbidgcaafaj", mirror, ok, 490232704 sectors, data@ 0
Comment 3 Heinz Mauelshagen 2006-07-04 10:41:20 EDT
That's fine. ATARAID metadata (e.g. sil) usually is extremely small.
Please create with .rc8 and pack as described in comment #1.
Thanks.
Comment 4 matti aarnio 2006-07-04 10:46:12 EDT
Created attachment 131904 [details]
two JBODs + one pair of RAID1 on SiI 3114

finally understood what gentlement did mean --- -vvv  gave
enough clue of dump-files being written..
Comment 5 Heinz Mauelshagen 2006-07-04 11:56:46 EDT
Is this all primary partitions ?

Please attach the partition sector created by e.g. 
'dd if=/dev/sil_afbidgcaafaj bs=512 count=1 of=sil_afbidgcaafaj.partition_table'
and the 'fdisk -lu' output as well.
Comment 6 matti aarnio 2006-07-04 12:54:41 EDT
Created attachment 131908 [details]
SIL RAID1 disk partition table sector
Comment 7 matti aarnio 2006-07-04 12:55:57 EDT
Created attachment 131909 [details]
"fdisk -lu" output (sans stderr) in the system
Comment 8 Heinz Mauelshagen 2006-07-06 10:19:13 EDT
Heads up: still investigating, why dmraid doesn't activate the partitions.

Can you try running 'kpartx -a /dev/mapper/sil_afbidgcaafaj' after 'dmraid -ay'
and see if that gives you your partition table mappings as a workaround ?

FYI: I'ld want to get rid of the partition table activation in dmraid in favour
of kpartx anyway later.
Comment 9 Heinz Mauelshagen 2006-07-06 12:00:13 EDT
Found the bug and put
people.redhat.com/heinzm/sw/dmraid/tst/dmraid-1.0.0.rc12-pre1.static binary up
for testing.
Please download, run 'dmraid-1.0.0.rc12-pre1.static -vay' and report.
Comment 10 matti aarnio 2006-07-07 10:08:23 EDT
  Shrinking the output a bit with:  -f sil

# /tmp/dmraid-1.0.0.rc12-pre1.static -f sil -ay -v -v -v -v
NOTICE: checking format identifier sil
WARN: locking /var/lock/dmraid/.lock
NOTICE: skipping removable device /dev/sdg
NOTICE: skipping removable device /dev/sdf
NOTICE: skipping removable device /dev/sde
NOTICE: /dev/sda: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sda: sil metadata discovered
NOTICE: /dev/sdb: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdb: sil metadata discovered
NOTICE: /dev/sdc: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdc: sil metadata discovered
NOTICE: /dev/sdd: sil     discovering
NOTICE: sil: areas 1,2,3,4[4] are valid
NOTICE: /dev/sdd: sil metadata discovered
NOTICE: added /dev/sda to RAID set "sil_afbgdjdeddbb"
NOTICE: added /dev/sdb to RAID set "sil_afbgdjdecfbd"
NOTICE: added /dev/sdc to RAID set "sil_afbidgcaafaj"
NOTICE: added /dev/sdd to RAID set "sil_afbidgcaafaj"
INFO: Activating mirror RAID set "sil_afbidgcaafaj"
NOTICE: discovering partitions on "sil_afbgdjdeddbb"
NOTICE: /dev/mapper/sil_afbgdjdeddbb: dos     discovering
ERROR: dos: reading /dev/mapper/sil_afbgdjdeddbb[No such file or directory]
NOTICE: discovering partitions on "sil_afbgdjdecfbd"
NOTICE: /dev/mapper/sil_afbgdjdecfbd: dos     discovering
ERROR: dos: reading /dev/mapper/sil_afbgdjdecfbd[No such file or directory]
NOTICE: discovering partitions on "sil_afbidgcaafaj"
NOTICE: /dev/mapper/sil_afbidgcaafaj: dos     discovering
NOTICE: /dev/mapper/sil_afbidgcaafaj: dos metadata discovered
NOTICE: created partitioned RAID set(s) for /dev/mapper/sil_afbidgcaafaj
INFO: Activating partition RAID set "sil_afbidgcaafaj1"
INFO: Activating partition RAID set "sil_afbidgcaafaj2"
INFO: Activating partition RAID set "sil_afbidgcaafaj3"
WARN: unlocking /var/lock/dmraid/.lock


  Kernel complains a bit:

device-mapper: table: 253:0: linear: dm-linear: Device lookup failed
device-mapper: ioctl: error adding target to table
device-mapper: table: 253:1: linear: dm-linear: Device lookup failed
device-mapper: ioctl: error adding target to table


# ls -l /dev/mapper/
total 0
crw------- 1 root root  10, 63 Jul  3 22:34 control
brw-rw---- 1 root disk 253,  1 Jul  7 17:09 sil_afbgdjdecfbd
brw-rw---- 1 root disk 253,  0 Jul  7 17:09 sil_afbgdjdeddbb
brw-rw---- 1 root disk 253,  2 Jul  7 17:09 sil_afbidgcaafaj
brw-rw---- 1 root disk 253,  3 Jul  7 17:09 sil_afbidgcaafaj1
brw-rw---- 1 root disk 253,  4 Jul  7 17:09 sil_afbidgcaafaj2
brw-rw---- 1 root disk 253,  5 Jul  7 17:09 sil_afbidgcaafaj3


OK - raid1 partition works, I wonder why the "dm-linear" complains ?


About the  kpartx: is it in right place being in  device-mapper-multipath ?
I don't need multipath myself, but if that utility will be needed...
Comment 11 matti aarnio 2006-07-07 10:36:33 EDT
The  kpartx  is indeed able to create those partition labels,
but it isn't in default installations "'cause this machine has
no multipathing thingamajing.."
Comment 12 matti aarnio 2006-07-07 16:25:20 EDT
The "dm-linear"'s complaint may be because the SDA/SDB devices are
already bound to MD.
Comment 13 Heinz Mauelshagen 2006-11-20 08:39:28 EST
All dmraid versions since 1.0.0.rc12 should have the bug fixed now.
Closing.

Note You need to log in before you can comment on or make changes to this bug.