Bug 197589 - openoffice crashes
openoffice crashes
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-04 07:58 EDT by John Smith
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-05 03:48:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text that ooffice asked to paste into bugreport (2.42 KB, application/octet-stream)
2006-07-04 07:58 EDT, John Smith
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 67035 None None None Never

  None (edit)
Description John Smith 2006-07-04 07:58:59 EDT
Description of problem:
openoffice crashed and gave some text to paste into a bug report.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.1.1-7.1

How reproducible:
not reproducible
Comment 1 John Smith 2006-07-04 07:58:59 EDT
Created attachment 131899 [details]
text that ooffice asked to paste into bugreport
Comment 2 Caolan McNamara 2006-07-04 08:22:52 EDT
you set this to FC-5, but it must have come from FC-4 yes ?
Comment 3 Caolan McNamara 2006-07-04 08:31:24 EDT
looks like this mapped back to code

1        50%    /usr/src/debug/OOA680_m1/sal/osl/unx/signal.c:484       ReportCrash
2        50%    /usr/src/debug/OOA680_m1/sal/osl/unx/signal.c:811      
SignalHandlerFunction
3         0%    0xa15420:  + 0x420 (__kernel_sigreturn + 0x0)
4        75%    /usr/src/debug/OOA680_m1/sw/source/core/layout/layact.cxx:2859 
SwLayIdle::SwLayIdle[in-charge](SwRootFrm*, SwViewImp*)
5       100%    /usr/src/debug/OOA680_m1/sw/source/core/view/viewsh.cxx:759    
ViewShell::LayoutIdle()
6        75%    /usr/src/debug/OOA680_m1/sw/source/core/doc/doclay.cxx:1916    
SwDoc::DoIdleJobs(Timer*)
7        75%    /usr/src/debug/OOA680_m1/sw/source/core/doc/doclay.cxx:1895    
SwDoc::LinkStubDoIdleJobs(void*, void*)
8        75%   
/usr/src/debug/OOA680_m1/solver/680/unxlngi6.pro/inc/tools/link.hxx:154
Link::Call(void*) const
9       100%    /usr/src/debug/OOA680_m1/vcl/source/app/timer.cxx:281  
Timer::Timeout()
10       75%    /usr/src/debug/OOA680_m1/vcl/source/app/timer.cxx:170  
ImplTimerCallbackProc()
11       75%    ../../../inc/saltimer.hxx:81    SalTimer::CallCallback()
12      100%    /usr/src/debug/OOA680_m1/vcl/unx/source/app/saltimer.cxx:66    
SalData::Timeout() const
13       50%    /usr/src/debug/OOA680_m1/vcl/unx/gtk/app/gtkdata.cxx:584       
GtkXLib::timeoutFn(void*)
14       50%    0x123cfe6: /usr/lib/libglib-2.0.so.0 + 0x24fe6
15       50%    0x123b4ce: /usr/lib/libglib-2.0.so.0 + 0x234ce
(g_main_context_dispatch + 0x1dc)
16       50%    0x123e4d6: /usr/lib/libglib-2.0.so.0 + 0x264d6
17       50%    0x123e9b8: /usr/lib/libglib-2.0.so.0 + 0x269b8
(g_main_context_iteration + 0x66)
18       50%    /usr/src/debug/OOA680_m1/vcl/unx/gtk/app/gtkdata.cxx:696       
GtkXLib::Yield(unsigned char)
19      100%    /usr/src/debug/OOA680_m1/vcl/unx/source/app/salinst.cxx:290    
X11SalInstance::Yield(unsigned char)
20      100%    /usr/src/debug/OOA680_m1/vcl/source/app/svapp.cxx:540  
Application::Yield()
21      100%    /usr/src/debug/OOA680_m1/vcl/source/app/svapp.cxx:500  
Application::Execute()
22      100%    /usr/src/debug/OOA680_m1/desktop/source/app/app.cxx:1693       
desktop::Desktop::Main()
23       75%    /usr/src/debug/OOA680_m1/vcl/source/app/svmain.cxx:242  ImplSVMain()
24      100%    /usr/src/debug/OOA680_m1/vcl/source/app/svmain.cxx:273  SVMain()
25      100%    /usr/src/debug/OOA680_m1/desktop/source/app/main.cxx:77 sal_main
26      100%    /usr/src/debug/OOA680_m1/desktop/source/app/main.cxx:71 main
27       50%    0xa48d7f: /lib/libc.so.6 + 0x14d7f (__libc_start_main + 0xdf)
28       50%    ??:0    ??
Comment 4 Caolan McNamara 2006-07-04 08:38:39 EDT
blither, line 2859

   2846                 USHORT nBoolIdx = 0;
   2847                 do
   2848                 {       --pSh->nStartAction;
   2849
   2850                         if ( pSh->Imp()->GetRegion() ||
pSh->Imp()->GetScrollRects() )
   2851                                 bActions = TRUE;
   2852                         else
   2853                         {
   2854                                 SwRect aTmp( pSh->VisArea() );
   2855                                 pSh->UISizeNotify();
   2856
   2857                                 bActions |= aTmp != pSh->VisArea() ||
   2858                                                         aBools[nBoolIdx] !=
   2859                                                                   
((SwCrsrShell*)pSh)->GetCharRect().IsOver(pSh->VisArea(
   2859 ));
   2860                         }
   2861
   2862                         pSh = (ViewShell*)pSh->GetNext();
   2863                         ++nBoolIdx;
   2864                 } while ( pSh != pImp->GetShell() );
Comment 5 Caolan McNamara 2006-07-05 03:48:46 EDT
Can't see immediately what the problem might be, but the stacktrace is a good
one, so upstreamed as http://www.openoffice.org/issues/show_bug.cgi?id=67035 to
the writer layout guy in charge of this area
Comment 6 Caolan McNamara 2006-07-05 05:02:41 EDT
So it turns out that this is a known, but unreproducable problem. Can you
remember  what you were doing at the time, or what documents you had opened, or
if there were anything unusual about the documents opened.

Note You need to log in before you can comment on or make changes to this bug.