Bug 197599 - unresolved symbol in ldd -r output
unresolved symbol in ldd -r output
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-04 09:50 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.6.6a-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-04 11:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-07-04 09:50:54 EDT
Description of problem:
This might not be a problem if libm is dlopen'ed, otherwise it looks like 
'-lm' is missing somewhere in the makefiles:


ldd -r /usr/lib64/libhpip.so.0.0.1:
undefined symbol: sqrt  (/usr/lib64/libhpip.so.0.0.1)
undefined symbol: floor (/usr/lib64/libhpip.so.0.0.1)
undefined symbol: pow   (/usr/lib64/libhpip.so.0.0.1)


Version-Release number of selected component (if applicable):
libsane-hpaio-1.6.6a-2 / hplip-1.6.6a-2.src.rpm
Comment 1 Tim Waugh 2006-07-04 11:09:08 EDT
Fixed in 1.6.6a-3.

Note You need to log in before you can comment on or make changes to this bug.