Bug 197675 - suspend does not works with kernel-2.6.17-1.2339.fc6
suspend does not works with kernel-2.6.17-1.2339.fc6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 197913 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-05 09:49 EDT by Carlos "casep" Sepulveda
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.17-1.2358.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-03 17:42:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos "casep" Sepulveda 2006-07-05 09:49:45 EDT
Description of problem: After intall the kernel kernel-2.6.17-1.2339.fc6 suspend
does not work any more on my T23.
Suspend (memory and disk) works fine with the kernel-2.6.17-1.2339.fc6.
Suspend is called via the gnome-power-manager.


Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2339.fc6


How reproducible:
Every time.

Steps to Reproduce:
1.Install kernel-2.6.17-1.2339.fc6.
2.On gnome, click on the gnome-power-manager to suspend.

  
Actual results:
Screen goes black then return to screen saver.

Expected results:
Machine suspended.

Additional info:
Content of /var/log/messages

Jul  4 10:20:28 localhost kernel: Freezing cpus ...
Jul  4 10:20:28 localhost kernel: Stopping tasks:
====================================================================================================
===================================
Jul  4 10:20:28 localhost kernel:  stopping tasks timed out after 20 seconds (8
tasks remaining):
Jul  4 10:20:28 localhost kernel:   rt-test-0
Jul  4 10:20:28 localhost kernel:   rt-test-1
Jul  4 10:20:28 localhost kernel:   rt-test-2
Jul  4 10:20:28 localhost kernel:   rt-test-3
Jul  4 10:20:28 localhost kernel:   rt-test-4
Jul  4 10:20:28 localhost kernel:   rt-test-5
Jul  4 10:20:28 localhost kernel:   rt-test-6
Jul  4 10:20:28 localhost kernel:   rt-test-7
Jul  4 10:20:28 localhost kernel: Restarting tasks...<6> Strange, rt-test-0 not
stopped
Jul  4 10:20:28 localhost kernel:  Strange, rt-test-1 not stopped
Jul  4 10:20:28 localhost kernel:  Strange, rt-test-2 not stopped
Jul  4 10:20:28 localhost kernel:  Strange, rt-test-3 not stopped
Jul  4 10:20:28 localhost kernel:  Strange, rt-test-4 not stopped
Jul  4 10:20:28 localhost kernel:  Strange, rt-test-5 not stopped
Jul  4 10:20:28 localhost kernel:  Strange, rt-test-6 not stopped
Jul  4 10:20:28 localhost kernel:  Strange, rt-test-7 not stopped
Jul  4 10:20:28 localhost gnome-power-manager: Resuming computer
Jul  4 10:20:28 localhost NetworkManager: <information> Waking up from sleep.
Jul  4 10:20:28 localhost NetworkManager: <information> Deactivating device eth1.
Jul  4 10:20:28 localhost gnome-power-manager: Screen dim because idle mode started
Jul  4 10:20:28 localhost restorecond: Read error (Interrupted system call)
Jul  4 10:20:28 localhost kernel:  done
Jul  4 10:20:28 localhost kernel: Thawing cpus ...
Jul  4 10:20:30 localhost kernel: ACPI: Power Button (FF) [PWRF]
Jul  4 10:20:30 localhost kernel: ACPI: Lid Switch [LID]
Jul  4 10:20:30 localhost kernel: ACPI: Sleep Button (CM) [SLPB]
Jul  4 10:20:30 localhost NetworkManager: <information> Deactivating device
dev1804289383.
Comment 1 Carlos "casep" Sepulveda 2006-07-05 10:00:30 EDT
Suspend (memory and disk) works fine with the kernel-2.6.17-1.2339.fc6.
Must says 
Suspend (memory and disk) works fine with the kernel-2.6.16-1.2289_FC6
Comment 2 Carlos "casep" Sepulveda 2006-07-07 16:48:25 EDT
Neither the 2.6.17-1.2356.fc6 works

Contents of lspci (It's a Thinkpad T23)
00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corporation 82830 830 Chipset AGP Bridge (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #1) (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #2) (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801CA/CAM USB (Hub #3) (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 (rev 02)
00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio
Controller (rev 02)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 02)
01:00.0 VGA compatible controller: S3 Inc. SuperSavage IX/C SDR (rev 05)
02:00.0 CardBus bridge: Texas Instruments PCI1420
02:00.1 CardBus bridge: Texas Instruments PCI1420
02:02.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 01)
02:08.0 Ethernet controller: Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM)
Ethernet Controller (rev 42)
Comment 3 Bill Nottingham 2006-07-07 16:50:48 EDT
This is fixed with 2358, AFAICT.
Comment 4 Carlos "casep" Sepulveda 2006-07-14 10:17:52 EDT
Ok, it's working again with the 2.6.17-1.2366.fc6

But with this* one I got this on /var/log/message

So, I should close this bug and open another for the orther stuff? 

*
Jul 14 10:11:09 localhost kernel: Stopping tasks:
================================================================
===========================================================|
Jul 14 10:11:09 localhost kernel: pnp: Device 00:0b disabled.
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:02:08.0
disabled
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:02:02.0
disabled
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:02:00.1
disabled
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:02:00.0
disabled
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:00:1f.6
disabled
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:00:1f.5
disabled
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:00:1d.2
disabled
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:00:1d.1
disabled
Jul 14 10:11:09 localhost kernel: ACPI: PCI interrupt for device 0000:00:1d.0
disabled
Jul 14 10:11:09 localhost kernel: Intel machine check architecture supported.
Jul 14 10:11:09 localhost kernel: Intel machine check reporting enabled on CPU#0.
Jul 14 10:11:09 localhost kernel: BUG: sleeping function called from invalid
context at kernel/rwsem.c:20
Jul 14 10:11:09 localhost kernel: in_atomic():0, irqs_disabled():1
Jul 14 10:11:09 localhost kernel:  [<c04050bb>] show_trace_log_lvl+0x57/0xf3
Jul 14 10:11:09 localhost kernel:  [<c040570d>] show_trace+0xf/0x11
Jul 14 10:11:09 localhost kernel:  [<c0405810>] dump_stack+0x15/0x17
Jul 14 10:11:09 localhost kernel:  [<c0438782>] down_read+0x12/0x20
Jul 14 10:11:09 localhost kernel:  [<c0430443>]
blocking_notifier_call_chain+0xe/0x29
Jul 14 10:11:09 localhost kernel:  [<c05a6ecc>] cpufreq_resume+0x118/0x135
Jul 14 10:11:09 localhost kernel:  [<c054cdbc>] __sysdev_resume+0x20/0x53
Jul 14 10:11:09 localhost kernel:  [<c054ceff>] sysdev_resume+0x16/0x47
Jul 14 10:11:09 localhost kernel:  [<c055182b>] device_power_up+0x5/0xa
Jul 14 10:11:09 localhost kernel:  [<c0440aa9>] suspend_enter+0x3b/0x44
Jul 14 10:11:09 localhost kernel:  [<c0440c1a>] enter_state+0x168/0x1cb
Jul 14 10:11:09 localhost kernel:  [<c0440d02>] state_store+0x85/0x99
Jul 14 10:11:09 localhost kernel:  [<c04a789e>] subsys_attr_store+0x1e/0x22
Jul 14 10:11:09 localhost kernel:  [<c04a798b>] sysfs_write_file+0xa4/0xcb
Jul 14 10:11:09 localhost restorecond: Read error (Interrupted system call)
Jul 14 10:11:09 localhost kernel:  [<c046ee2d>] vfs_write+0xa8/0x159
Jul 14 10:11:09 localhost kernel:  [<c046f455>] sys_write+0x41/0x67
Jul 14 10:11:09 localhost kernel:  [<c0403f17>] syscall_call+0x7/0xb
Jul 14 10:11:09 localhost kernel: BUG: sleeping function called from invalid
context at include/asm/semaphore.h:99
Jul 14 10:11:09 localhost kernel: in_atomic():0, irqs_disabled():1
Jul 14 10:11:09 localhost kernel:  [<c04050bb>] show_trace_log_lvl+0x57/0xf3
Jul 14 10:11:09 localhost kernel:  [<c040570d>] show_trace+0xf/0x11
Jul 14 10:11:09 localhost kernel:  [<c0405810>] dump_stack+0x15/0x17
Jul 14 10:11:09 localhost kernel:  [<c0503c1e>] acpi_os_wait_semaphore+0x52/0xad
Jul 14 10:11:09 localhost kernel:  [<c051aa7f>] acpi_ut_acquire_mutex+0x34/0x7d
Jul 14 10:11:09 localhost kernel:  [<c0512bee>] acpi_ns_get_node+0x41/0x93
Jul 14 10:11:09 localhost kernel:  [<c0512536>] acpi_ns_evaluate+0x2e/0xfc
Jul 14 10:11:09 localhost kernel:  [<c051648f>]
acpi_rs_set_srs_method_data+0xcb/0xe7
Jul 14 10:11:09 localhost kernel:  [<c0515e30>] acpi_set_current_resources+0x2a/0x34
Jul 14 10:11:09 localhost kernel:  [<c051e344>] acpi_pci_link_set+0xfc/0x1b7
Jul 14 10:11:09 localhost kernel:  [<c051e44b>] irqrouter_resume+0x4c/0x61
Jul 14 10:11:09 localhost kernel:  [<c054cdad>] __sysdev_resume+0x11/0x53
Jul 14 10:11:09 localhost kernel:  [<c054ceff>] sysdev_resume+0x16/0x47
Jul 14 10:11:09 localhost kernel:  [<c055182b>] device_power_up+0x5/0xa
Jul 14 10:11:09 localhost kernel:  [<c0440aa9>] suspend_enter+0x3b/0x44
Jul 14 10:11:09 localhost kernel:  [<c0440c1a>] enter_state+0x168/0x1cb
Jul 14 10:11:09 localhost kernel:  [<c0440d02>] state_store+0x85/0x99
Jul 14 10:11:09 localhost kernel:  [<c04a789e>] subsys_attr_store+0x1e/0x22
Jul 14 10:11:09 localhost kernel:  [<c04a798b>] sysfs_write_file+0xa4/0xcb
Jul 14 10:11:09 localhost kernel:  [<c046ee2d>] vfs_write+0xa8/0x159
Jul 14 10:11:09 localhost kernel:  [<c046f455>] sys_write+0x41/0x67
Jul 14 10:11:09 localhost kernel:  [<c0403f17>] syscall_call+0x7/0xb
Jul 14 10:11:09 localhost kernel: PCI: Enabling device 0000:00:1d.0 (0000 -> 0001)
Jul 14 10:11:09 localhost kernel: ACPI: PCI Interrupt 0000:00:1d.0[A] -> Link
[LNKA] -> GSI 11 (level, low) -> IRQ  11
Jul 14 10:11:09 localhost kernel: usb usb1: root hub lost power or was reset
Jul 14 10:11:09 localhost kernel: PCI: Enabling device 0000:00:1d.1 (0000 -> 0001)
Jul 14 10:11:09 localhost kernel: ACPI: PCI Interrupt 0000:00:1d.1[B] -> Link
[LNKD] -> GSI 11 (level, low) -> IRQ  11
Jul 14 10:11:09 localhost kernel: usb usb2: root hub lost power or was reset
Jul 14 10:11:09 localhost kernel: PCI: Enabling device 0000:00:1d.2 (0000 -> 0001)
Jul 14 10:11:09 localhost kernel: ACPI: PCI Interrupt 0000:00:1d.2[C] -> Link
[LNKC] -> GSI 11 (level, low) -> IRQ  11
Jul 14 10:11:09 localhost kernel: usb usb3: root hub lost power or was reset
Jul 14 10:11:09 localhost kernel: PCI: Enabling device 0000:00:1f.5 (0000 -> 0001)
Jul 14 10:11:09 localhost kernel: ACPI: PCI Interrupt 0000:00:1f.5[B] -> Link
[LNKB] -> GSI 11 (level, low) -> IRQ  11
Jul 14 10:11:09 localhost kernel: PCI: Enabling device 0000:00:1f.6 (0000 -> 0001)
Jul 14 10:11:09 localhost kernel: ACPI: PCI Interrupt 0000:00:1f.6[B] -> Link
[LNKB] -> GSI 11 (level, low) -> IRQ  11
Jul 14 10:11:09 localhost kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> Link
[LNKA] -> GSI 11 (level, low) -> IRQ  11
Jul 14 10:11:09 localhost kernel: ACPI: PCI Interrupt 0000:02:00.1[B] -> Link
[LNKB] -> GSI 11 (level, low) -> IRQ  11
Jul 14 10:11:09 localhost kernel: ACPI: PCI Interrupt 0000:02:02.0[A] -> Link
[LNKC] -> GSI 11 (level, low) -> IRQ  11
Jul 14 10:11:09 localhost kernel: pnp: Device 00:07 does not support activation.
Jul 14 10:11:09 localhost kernel: pnp: Device 00:08 does not support activation.
Jul 14 10:11:09 localhost kernel: pnp: Device 00:0b activated.
Jul 14 10:11:09 localhost kernel: Restarting tasks...<6>usb 1-1: USB disconnect,
address 2
Jul 14 10:11:09 localhost kernel: usb 1-1.3: USB disconnect, address 3
Jul 14 10:11:09 localhost kernel:  done
Jul 14 10:11:09 localhost kernel: Thawing cpus ...
Jul 14 10:11:09 localhost kernel: usb 1-1: new full speed USB device using
uhci_hcd and address 4
Jul 14 10:11:09 localhost kernel: usb 1-1: configuration #1 chosen from 1 choice
Jul 14 10:11:09 localhost kernel: hub 1-1:1.0: USB hub found
Jul 14 10:11:09 localhost kernel: hub 1-1:1.0: 4 ports detected
Jul 14 10:11:09 localhost kernel: usb 1-1.3: new low speed USB device using
uhci_hcd and address 5
Jul 14 10:11:10 localhost kernel: usb 1-1.3: configuration #1 chosen from 1 choice
Jul 14 10:11:10 localhost kernel: input: Logitech USB Receiver as
/class/input/input4
Jul 14 10:11:10 localhost kernel: input: USB HID v1.10 Mouse [Logitech USB
Receiver] on usb-0000:00:1d.0-1.3
Comment 5 Dan Carpenter 2006-08-08 05:40:59 EDT
That new bug is the same as bug 201508.
Comment 6 Nigel Cunningham 2006-12-03 17:42:35 EST
The new issue should be harmless, too (the complaint is valid, but the issue 
shouldn't cause problems). Closing this bug, since the original issue is now 
fixed.
Comment 7 Nigel Cunningham 2006-12-03 17:51:21 EST
*** Bug 197913 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.