Bug 197700 - Yum update caused lpr/llpr to report invalid options
Yum update caused lpr/llpr to report invalid options
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-05 12:28 EDT by Colin Ager
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 05:22:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Ager 2006-07-05 12:28:19 EDT
Description of problem:Since doing a fairly major update wih YUM I can no longer
print from the command line using LPR/LLPR. I get the lpr gui but when I select
a printer and click print the command line reports invalid option -d then
invalid option -n and finally invalid option -p. Other applications which print
via cups work ok but Mozilla(suite) seems to be using lpr and also cannot print.


Version-Release number of selected component (if applicable):unknown


How reproducible:every time


Steps to Reproduce:
1Enter Shell

2.cd /etc (for example)
3.ls | lpr
  
Actual results:As stated above


Expected results:Print gui->select printer->print->printer activated


Additional info:lpr/llpr worked normally before update.
Comment 1 Colin Ager 2006-07-07 11:41:07 EDT
I have discovered that the gui I referred to is in fact generated by the Samsung
"Linux Printing Package" and and in the Samsung FAQ part of Linux Printing.org
there is a note that it doesn't work with CUPS as it sends invalid options
lp.(NB  It did work before the YUM update which I think changed something in
Mozilla.There is also a referance to a script which can correct this but the
links are broken.I have found an updated version of LPP
(20050422164643515_lpp-1.1.7-27-I386.tar.gz) updated 2006-03-29
on the Samsung support site and on removing the old version and loading this I
can now print from the shell. Printing from Mozilla is still a bit flakey but
can be done with a bit of fiddling.
Comment 2 Tim Waugh 2006-07-26 05:22:22 EDT
Problem originated with Samsung package -> out of our control.

Note You need to log in before you can comment on or make changes to this bug.