Bug 197742 - kernel installs prevented by avc denials.
kernel installs prevented by avc denials.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-05 17:48 EDT by Dave Jones
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-05 19:14:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-07-05 17:48:45 EDT
rpm -ivh kernel-2.6.17-1.2353.fc6.x86_64.rpm
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]


dmesg shows ...
audit(1152136489.347:11): avc:  denied  { write } for  pid=3452 comm="modprobe"
name="scsi_mod.ko" dev=dm-0 ino=11436647
scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:modules_object_t:s0 tclass=file
audit(1152136489.347:12): avc:  denied  { write } for  pid=3452 comm="modprobe"
name="libata.ko" dev=dm-0 ino=11436626 scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:modules_object_t:s0 tclass=file
audit(1152136489.351:13): avc:  denied  { write } for  pid=3452 comm="modprobe"
name="ahci.ko" dev=dm-0 ino=11436610 scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:modules_object_t:s0 tclass=file
audit(1152136493.779:14): avc:  denied  { search } for  pid=3791 comm="grubby"
name="home" dev=dm-0 ino=27328513 scontext=user_u:system_r:bootloader_t:s0
tcontext=system_u:object_r:home_root_t:s0 tclass=dir


I did a fixfiles relabel and retried - same thing.

selinux-policy-targeted-2.2.47-3.fc5
selinux-policy-2.2.47-3.fc5
Comment 1 Dave Jones 2006-07-05 18:00:07 EDT
hmm, I noticed there's a bunch of stuff that didn't get updated, including the
2.3 version of policy.

I'll yum update again, and see if that sorts out the policy.
Comment 2 Dave Jones 2006-07-05 19:14:37 EDT
was caused by an incomplete yum upgrade. works fine now.

Note You need to log in before you can comment on or make changes to this bug.